您的位置:首页 > 其它

HDU 1171 Big Event in HDU(多重背包)

2015-02-12 23:29 337 查看
题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1171

Big Event in HDU

Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 25844 Accepted Submission(s): 9092



Problem Description
Nowadays, we all know that Computer College is the biggest department in HDU. But, maybe you don't know that Computer College had ever been split into Computer College and Software College in 2002.

The splitting is absolutely a big event in HDU! At the same time, it is a trouble thing too. All facilities must go halves. First, all facilities are assessed, and two facilities are thought to be same if they have the same value. It is assumed that there is
N (0<N<1000) kinds of facilities (different value, different kinds).



Input
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 50 -- the total number of different facilities). The next N lines contain an integer V (0<V<=50 --value of facility) and an integer M (0<M<=100 --corresponding
number of the facilities) each. You can assume that all V are different.

A test case starting with a negative integer terminates input and this test case is not to be processed.



Output
For each case, print one line containing two integers A and B which denote the value of Computer College and Software College will get respectively. A and B should be as equal as possible. At the same time, you should guarantee that
A is not less than B.



Sample Input
2
10 1
20 1
3
10 1 
20 2
30 1
-1




Sample Output
20 10
40 40


此题可转化为代价和价值相等,背包容量为(总价值/2)的多重背包问题。

#include<cstdio>
#include<cstring>
#include<cmath>
#include<cstdlib>
#include<iostream>
#include<algorithm>
#include<sstream>
#include<vector>
#include<map>
#include<stack>
#include<list>
#include<set>
#include<queue>
#define LL long long
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1 | 1
using namespace std;
const int maxn=250005;
int v[maxn],W,dp[maxn],n,num[maxn];
void ZeroOnePack(int weight,int value)
{
    for(int i=W;i>=weight;i--)
        dp[i]=max(dp[i],dp[i-weight]+value);
}
void CompletePack(int weight,int value)
{
    for(int i=weight;i<=W;i++)
        dp[i]=max(dp[i],dp[i-weight]+value);
}
void MultiplePack(int weight,int value,int cnt)
{
    if(weight*cnt>=W) CompletePack(weight,value);
    else
    {
        for(int k=1;k<cnt;k<<=1)
            ZeroOnePack(k*weight,k*value),cnt-=k;
        ZeroOnePack(cnt*weight,cnt*value);
    }
}
int main()
{
    while(cin>>n&&n>=0)
    {
        int sum=0;
        for(int i=0;i<n;i++) cin>>v[i]>>num[i],sum+=v[i]*num[i];
        fill(dp,dp+maxn,0);
        W=sum/2;
        for(int i=0;i<n;i++) MultiplePack(v[i],v[i],num[i]);
        cout<<sum-dp[W]<<" "<<dp[W]<<endl;
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: