您的位置:首页 > 其它

ACM-一道简单的排序题(HDOJ 1031)Design T-Shirt

2015-01-26 17:05 295 查看
这道题理解之后很简单,所以发这道题也不是为了写下来思路,而是小总结。

刚看到这道题,理解了很久,然后看数据的时候,因为有一个小数影响了排版,把他们的总和计算错了

百度这道题,发现没怎么有。好吧,主要是太简单。

过一会再做的时候,我心想写一部分试试,还是刚才的思路,求和之后发现刚才看错了,

看错了之后自己也没有信心去做这道题。只到试出来怎么做。

题目就是一个简单的二次排序。先求和,然后编号排序。


Design T-Shirt

Problem Description

Soon after he decided to design a T-shirt for our Algorithm Board on Free-City BBS, XKA found that he was trapped by all kinds of suggestions from everyone on the board. It is indeed a mission-impossible to have everybody perfectly satisfied. So he took a poll
to collect people's opinions. Here are what he obtained: N people voted for M design elements (such as the ACM-ICPC logo, big names in computer science, well-known graphs, etc.). Everyone assigned each element a number of satisfaction. However, XKA can only
put K (<=M) elements into his design. He needs you to pick for him the K elements such that the total number of satisfaction is maximized.



Input

The input consists of multiple test cases. For each case, the first line contains three positive integers N, M and K where N is the number of people, M is the number of design elements, and K is the number of elements XKA will put into his design. Then N lines
follow, each contains M numbers. The j-th number in the i-th line represents the i-th person's satisfaction on the j-th element.



Output

For each test case, print in one line the indices of the K elements you would suggest XKA to take into consideration so that the total number of satisfaction is maximized. If there are more than one solutions, you must output the one with minimal indices. The
indices start from 1 and must be printed in non-increasing order. There must be exactly one space between two adjacent indices, and no extra space at the end of the line.



Sample Input

3 6 4 2 2.5 5 1 3 4 5 1 3.5 2 2 2 1 1 1 1 1 10 3 3 2 1 2 3 2 3 1 3 1 2




Sample Output

6 5 3 1 2 1


#include<stdio.h>
#include<algorithm>
#include<string.h>
using namespace std;
int cmp2(int a,int b)
{
    return a>b;
}
struct e
{
    int xh;
    double f;
}b[100];
int cmp(e  a,e  b)
{
    if(a.f==b.f) return a.xh<b.xh;
    else return a.f>b.f;
}
int main()
{
    int n,m,k,i,j;
    while(scanf("%d%d%d",&n,&m,&k)!=EOF)
    {double a[100][100],c[100];
    int q=0;int f=0;
    memset(b,0,sizeof(b));
  for(i=0;i<n;i++)
   for(j=0;j<m;j++)
   {
    scanf("%lf",&a[i][j]);
    b[j].f+=a[i][j];
   }
   for(i=0;i<m;i++) b[i].xh=i+1;
   sort(b,b+m,cmp);
for(i=0;i<k;i++)   c[q++]=b[i].xh;
sort(c,c+q,cmp2);
for(i=0;i<k;i++){if(f) printf(" ");f=1;
printf("%.0lf",c[i]);}printf("\n");
    }
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: