您的位置:首页 > 其它

hdu-1003-动态规划-求连续子序列最大和问题

2015-01-25 15:40 423 查看

Max Sum

[align=left]Problem Description[/align]
Given a sequence a[1],a[2],a[3]......a
, your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

[align=left]Input[/align]
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and
1000).

[align=left]Output[/align]
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end
position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

[align=left]Sample Input[/align]

2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5


[align=left]Sample Output[/align]

Case 1:
14 1 4

Case 2:
7 1 6


[align=left]Author[/align]
Ignatius.L

题意:求连续子序列最大和

状态转移方程:sum[i] = max{sum[i-1]+a[i],a[i]}. (sum[i]记录以a[i]为子序列末端的最大连续和。)在dp的过程中便可以更新sum数组的最大值以及两个边界。(此处参考hcbbt的博客)

伪代码:

sum←(-∞)
max←(-∞)
for i←1 to len do
if sum+arr[i]<arr[i] then
sum←arr[i]
else
sum←sum+arr[i]
end if
if max<sum then
max←sum
end if
end for
return max


#include<stdio.h>
#include<vector>
#include<algorithm>
#include<string.h>
#define minn -99999999
using namespace std;
int a[100005];
int main()
{
int i,n,m,max,sum,cnt=1,st,ed,temp;
scanf("%d",&n);
while(n--)
{
max=sum=minn;
scanf("%d",&m);
for(i=1; i<=m; i++)
{
scanf("%d",&a[i]);
}
for(i=1; i<=m; i++)
{
if(sum+a[i]<a[i])
{
sum=a[i];
temp=i;
}
else
{
sum=sum+a[i];
}
if(max<sum)     //在更新max值时才更新st和ed的值
{
max=sum;
st=temp;
ed=i;
}
}
printf("Case %d:\n",cnt++);
printf("%d %d %d\n",max,st,ed);
if(n>0)
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: