您的位置:首页 > 其它

HDOJ2680 Choose the best route

2015-01-09 23:35 369 查看

Choose the best route

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 7725    Accepted Submission(s): 2562

[align=left]Problem Description[/align]
One day , Kiki wants to visit one of her friends. As she is liable to carsickness , she wants to arrive at her friend’s home as soon as possible . Now give you a map of the city’s traffic route, and the
stations which are near Kiki’s home so that she can take. You may suppose Kiki can change the bus at any station. Please find out the least time Kiki needs to spend. To make it easy, if the city have n bus stations ,the stations will been expressed as an integer
1,2,3…n.
 

[align=left]Input[/align]
There are several test cases.

Each case begins with three integers n, m and s,(n<1000,m<20000,1=<s<=n) n stands for the number of bus stations in this city and m stands for the number of directed ways between bus stations .(Maybe there are several ways between two bus stations .) s stands
for the bus station that near Kiki’s friend’s home.

Then follow m lines ,each line contains three integers p , q , t (0<t<=1000). means from station p to station q there is a way and it will costs t minutes .

Then a line with an integer w(0<w<n), means the number of stations Kiki can take at the beginning. Then follows w integers stands for these stations.

 

[align=left]Output[/align]
The output contains one line for each data set : the least time Kiki needs to spend ,if it’s impossible to find such a route ,just output “-1”.
 

[align=left]Sample Input[/align]

5 8 5
1 2 2
1 5 3
1 3 4
2 4 7
2 5 6
2 3 5
3 5 1
4 5 1
2
2 3
4 3 4
1 2 3
1 3 4
2 3 2
1
1

 

[align=left]Sample Output[/align]

1
-1
#include<cstdio>
#include<cstdlib>
#include<cstring>
#define inf    0x3f3f3f3f
using namespace std;
int map[1010][1010],d,s,n,w,m,dist[1010],vis[1010];
int getnext(){
int i,u=-1,t=inf;
for(i=1;i<=n;++i){
if(!vis[i]&&t>dist[i]){
t=dist[i];u=i;
}
}
return u;
}
int    dijkstra(){
int i,j,t;
for(i=1;i<=n;++i){
vis[i]=0;dist[i]=inf;
}
int u=0;dist[0]=0;
while(u!=-1){
for(i=0;i<=n;++i){
t=dist[u]+map[u][i];
if(dist[i]>t)dist[i]=t;
}
vis[u]=1;
if(vis[s])return dist[s];
u=getnext();
}
return -1;
}
int main()
{
int i,j,q,p;
while(scanf("%d%d%d",&n,&m,&s)==3){
memset(map,0x3f,sizeof(map));
for(i=0;i<m;++i){
scanf("%d%d%d",&q,&p,&d);
if(map[q][p]>d)map[q][p]=d;
}
scanf("%d",&w);
for(i=1;i<=w;++i){
scanf("%d",&j);
map[0][j]=0;
}
dist[s]=inf;
printf("%d\n",dijkstra());
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  HDOJ2680 Choose the