您的位置:首页 > 其它

UVA - 120 Stacks of Flapjacks

2014-12-17 19:47 281 查看
http://acm.hust.edu.cn/vjudge/problem/viewProblem.action?id=18284

以下翻译转载自:http://www.cnblogs.com/devymex/archive/2010/08/15/1799844.html

Background

背景

Stacks and Queues are often considered the bread and butter of data structures and find use in architecture, parsing, operating systems, and discrete event simulation. Stacks are also important in the theory of formal languages.

栈和队列常常被视为数据结构中的面包和黄油,广泛应用在体系结构、分析、操作系统和离散事件等领域。栈同时也在形式语言理论中发挥着重要的作用。

This problem involves both butter and sustenance in the form of pancakes rather than bread in addition to a finicky server who flips pancakes according to a unique, but complete set of rules.

这个问题是让一个挑剔的厨师按照独特而完备的一组规则翻动煎饼,以保持煎饼(而不是面包)中的黄油和营养素不被烧坏。(这句话实在不知道怎么翻译才好,还望各位老师指正!Ps. 这道题翻译的难度要比解题大多了!!)

The Problem

问题

Given a stack of pancakes, you are to write a program that indicates how the stack can be sorted so that the largest pancake is on the bottom and the smallest pancake is on the top. The size of a pancake is given by the pancake's diameter. All pancakes in
a stack have different diameters.

给定一叠煎饼,你要写一个程序计算出如何才能使这叠煎饼自底向上由大至小的排列。给定煎饼的半径作为其尺寸,一叠煎饼的大小各不相同。

Sorting a stack is done by a sequence of pancake "flips". A flip consists of inserting a spatula between two pancakes in a stack and flipping (reversing) the pancakes on the spatula (reversing the sub-stack). A flip is specified by giving the position of
the pancake on the bottom of the sub-stack to be flipped (relative to the whole stack). The pancake on the bottom of the whole stack has position 1 and the pancake on the top of a stack of n pancakes has position n.

为煎饼叠排序是通过一些列的“翻转”动作来完成的。一个翻转动作就是将一个小铲插到煎饼叠中的某两个煎饼之间,然后将小铲上面的所有煎饼翻转(倒转小铲上面的子栈)。每个翻转动作由其开始的位置给出,即小铲上面子栈中最底下一个煎饼的编号。整叠煎饼中最下面一个的位置为1,n个煎饼的叠中最上面一个的位置为n。

A stack is specified by giving the diameter of each pancake in the stack in the order in which the pancakes appear.

一个煎饼叠由一组表示其中各煎饼直径的数构成,它们排列的顺序就是给出的这些数的顺序。

For example, consider the three stacks of pancakes below (in which pancake 8 is the top-most pancake of the left stack):

比如下面三个煎饼叠(煎饼8是左边一叠的最上面的一个)

8 7 2

4 6 5

6 4 8

7 8 4

5 5 6

2 2 7

The stack on the left can be transformed to the stack in the middle via flip(3). The middle stack can be transformed into the right stack via the command flip(1).

左边一叠可以通过翻转第3个煎饼变成中间一叠的顺序。中间一叠可以通过翻转第1个煎饼变成右边一叠的顺序。

The Input

输入

The input consists of a sequence of stacks of pancakes. Each stack will consist of between 1 and 30 pancakes and each pancake will have an integer diameter between 1 and 100. The input is terminated by end-of-file. Each stack is given as a single line of
input with the top pancake on a stack appearing first on a line, the bottom pancake appearing last, and all pancakes separated by a space.

输入包括一系列煎饼叠。每叠都由1到30个煎饼组成,并且每个煎饼的直径都在 1到100之间。输入由EOF结束。每叠煎饼独占一行,最上面的在行首,最下面的在行尾,各煎饼中间由空格隔开。

The Output

输出

For each stack of pancakes, the output should echo the original stack on one line, followed by some sequence of flips that results in the stack of pancakes being sorted so that the largest diameter pancake is on the bottom and the smallest on top. For each
stack the sequence of flips should be terminated by a 0 (indicating no more flips necessary). Once a stack is sorted, no more flips should be made.

对应于每叠煎饼数据,必须在第一行输出原叠的内容,接下来输出一组翻转动作的序列,使得这一叠煎饼自底向上由大至小的排列。输出的每一组翻转动作序列都要由0来结束(表示不再进行翻转)。一旦一叠煎饼已经排好序,就不能再进行任何翻转。

Sample Input

输入示例

1 2 3 4 5

5 4 3 2 1

5 1 2 3 4

Sample Output

输出示例

1 2 3 4 5

0

5 4 3 2 1

1 0

5 1 2 3 4

1 2 0

这道题 理解题意有一定困难啊,特别是对于我这种蹩脚的英语水平的人。理解题意就比较好做了。
就是给一个序列排序的过程,并且第一个数标号为n,最后一个数标号为1,每次在两个数之间放一个铲子,把铲子上面的数都反转一次,输出操作的编号。

那么每次找出最大的数,如果不在第一位就换到第一位去,然后在翻转到排完序的位置。从n到1依次进行。

#include<cstdio>
#include<cstring>
using namespace std;

int get_max(int a[],int pos) //得到最大数
{
int i,m=pos;
for(i=1;i<pos;i++)
{
if(a[i]>a[m])
{
m=i;
}
}
return m;
}
int main()
{
//freopen("a.txt","r",stdin);
int b[35],c[2000],i,j,n,m;
char s[100];
while(gets(s))
{
int l=strlen(s),ans=0;
n=1;
for(i=0;i<l;i++)
{
if(s[i]>='0'&&s[i]<='9') ans=ans*10+s[i]-'0';
else
{
b
=ans;
n++;
ans=0;
}
}
b
=ans;
for(i=1;i<n;i++)
printf("%d ",b[i]);
printf("%d\n",b
);
int pos=n,step=0;
while(pos>0) //pos大于0就要执行下去
{
int ans=get_max(b,pos);
// printf("%d\n",ans);
if(ans<pos) //如果不在 合适位置
{
if(ans!=1) {++step;c[step]=n-ans+1;} //不在第一个位置 记录
m=ans; //翻转到第一位
for(i=1;i<=ans/2;i++)
{
int t=b[i];b[i]=b[m];b[m]=t;
m--;
}
m=pos;//翻转到合适位置
for(i=1;i<=pos/2;i++)
{
int t=b[i];b[i]=b[m];b[m]=t;
m--;
}
++step; c[step]=n-pos+1;
}
pos--;
}
for(i=1;i<=step;i++)
printf("%d ",c[i]);
printf("0\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: