您的位置:首页 > 编程语言 > Go语言

poj 1003 Hangover

2014-12-05 21:23 288 查看
Hangover

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 104363Accepted: 50832
Description

How far can you make a stack of cards overhang a table? If you have one card, you can create a maximum overhang of half a card length. (We're assuming that the cards must be perpendicular to the table.) With two cards you can make the top card overhang the
bottom one by half a card length, and the bottom one overhang the table by a third of a card length, for a total maximum overhang of 1/2
+ 1/3 = 5/6 card lengths. In general you can make n cards overhang by 1/2
+ 1/3 + 1/4 + ... + 1/(n + 1) card lengths, where the top card overhangs the second by 1/2, the second overhangs tha third by 1/3, the third overhangs the fourth by 1/4, etc., and the bottom card overhangs
the table by 1/(n + 1). This is illustrated in the figure below.



Input
The input consists of one or more test cases, followed by a line containing the number 0.00 that signals the end of the input. Each test case is a single line containing a positive floating-point number c whose value is at least
0.01 and at most 5.20; c will contain exactly three digits.
Output
For each test case, output the minimum number of cards necessary to achieve an overhang of at least c card lengths. Use the exact output format shown in the examples.
Sample Input
1.00
3.71
0.04
5.19
0.00

Sample Output
3 card(s)
61 card(s)
1 card(s)
273 card(s)
题目大意:一块板放在桌子上能悬空一半的长度,两块板能悬空2/1+1/3,依次类推,给出一个长度,求最少要几块板
思路:按照题目模拟就行了
2014,12,5

#include<stdio.h>
double a[500]={0};
double f(int n){
int i,j=2;
double sum=0.0;
for(i=0;i<n;i++,j++)
sum+=1.0/j;
return sum;
}
int main(){
int i;
double m;
for(i=2;i<300;i++)
a[i]=f(i);
while(scanf("%lf",&m),m){
if(m<0.5)
printf("1 card(s)\n");
else{
for(i=2;;i++){
if(a[i]>m){
printf("%d card(s)\n",i);
break;
}
}
}
}
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: