您的位置:首页 > 其它

A Famous Music Composer(南阳oj25)(一道无聊的英文题)

2014-12-04 01:40 253 查看


A Famous Music Composer

时间限制:1000 ms | 内存限制:65535 KB
难度:1

描述
Mr. B is a famous music composer. One of his most famous work was his set of preludes. These 24 pieces span the 24 musical keys (there are musically distinct 12 scale notes, and each may use major or minor tonality). The 12 distinct scale notes are:

A A#=Bb B C C#=DbD D#=Eb E F F#=Gb G G#=Ab
Five of the notes have two alternate names, as is indicated above with equals sign. Thus, there are 17 possible names of scale notes, but only 12 musically distinct notes. When using one of these as the keynote for a musical key, we can further distinguish
between major and minor tonalities. This gives 34 possible keys, of which 24 are musically distinct.
In naming his preludes, Mr. B used all the keys except the following 10, which were named instead by their alternate names:

Ab minor A# majorA# minor C# major Db minor
D# major D# minorGb major Gb minor G# major
Write a program that, given the name of a key, give an alternate name if it has one, or report the key name is unique.

输入Each test case is described by one line having the format "note tonality", where "note" is one of the 17 names for the scale notes given above, and "tonality" is either "major" or "minor" (quotes for clarify).
输出For each case output the required answer, following the format of the sample.
样例输入
Ab minor
D# major
G minor


样例输出
Case 1: G# minor
Case 2: Eb major
Case 3: UNIQUE


来源hdu
上传者
李如兵

#include<stdio.h>
#include<string.h>
int main()
{
	char a[10],s[10];//数组开大点,否则不会过!破题。 
	int kase=1;
	while(scanf("%s %s",a,s)!=EOF)
	{
		printf("Case %d: ",kase++);
		if(!strcmp(a,"A#")) printf("Bb %s\n",s);
		else if(!strcmp(a,"Bb")) printf("A# %s\n",s);
		else if(!strcmp(a,"C#")) printf("Db %s\n",s);
		else if(!strcmp(a,"Db")) printf("C# %s\n",s);
		else if(!strcmp(a,"D#")) printf("Eb %s\n",s);
		else if(!strcmp(a,"Eb")) printf("D# %s\n",s);
		else if(!strcmp(a,"F#")) printf("Gb %s\n",s);
		else if(!strcmp(a,"Gb")) printf("F# %s\n",s);
		else if(!strcmp(a,"G#")) printf("Ab %s\n",s);
		else if(!strcmp(a,"Ab")) printf("G# %s\n",s);
		else printf("UNIQUE\n");	
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: