您的位置:首页 > 其它

UVAOJ 10010 —— Where's Waldorf? 搜索(照着一个方向一直搜)

2014-12-03 10:28 267 查看


  Where's Waldorf? 
Given a m by n grid
of letters, ( 

),
and a list of words, find the location in the grid at which the word can be found. A word matches a straight, uninterrupted line of letters in the grid. A word can match the letters in the grid regardless of case (i.e. upper and lower case letters are to be
treated as the same). The matching can be done in any of the eight directions either horizontally, vertically or diagonally through the grid.


Input 

The input begins with a single positive integer on a line by itself indicating the number of the cases following, each of them as described below. This line is followed
by a blank line, and there is also a blank line between two consecutive inputs.

The input begins with a pair of integers, m followed by n, 

 in decimal
notation on a single line. The next m lines contain nletters each; this is the grid of letters in which the words of the list must be found. The letters in the grid may be in upper or lower case. Following the grid of letters, another integer k appears
on a line by itself ( 

). The next k lines of input contain the list of words to search for, one word per line.
These words may contain upper and lower case letters only (no spaces, hyphens or other non-alphabetic characters).


Output 

For each test case, the output must follow the description below. The outputs of two consecutive cases will be separated by a blank line.

For each word in the word list, a pair of integers representing the location of the corresponding word in the grid must be output. The integers must be separated by a single space. The first integer is the line in the grid where
the first letter of the given word can be found (1 represents the topmost line in the grid, and m represents the bottommost line). The second integer is the column in the grid where the first letter of the given word can be found (1 represents the
leftmost column in the grid, and n represents the rightmost column in the grid). If a word can be found more than once in the grid, then the location which is output should correspond to the uppermost occurence of the word (i.e. the occurence which
places the first letter of the word closest to the top of the grid). If two or more words are uppermost, the output should correspond to the leftmost of these occurences. All words can be found at least once in the grid.


Sample Input 

1

8 11
abcDEFGhigg
hEbkWalDork
FtyAwaldORm
FtsimrLqsrc
byoArBeDeyv
Klcbqwikomk
strEBGadhrb
yUiqlxcnBjf
4
Waldorf
Bambi
Betty
Dagbert


Sample Output 

2 5
2 3
1 2
7 8


Miguel Revilla

2000-08-22

找准一个方向一直搜,不改变方向

#include <stdio.h>
#include <string.h>
#include <ctype.h>

char mp[55][55];
char cz[25];

int n,m;

int bhx[] = {-1,-1,0,1,1,1,0,-1};
int bhy[] = {0,1,1,1,0,-1,-1,-1};

int flag;

bool dfs(int x,int y,int i,int xb)
{
if(cz[xb + 1] == '\0')
{
flag = 1;
return true;
}
int nx = x + bhx[i];
int ny = y + bhy[i];
if(nx >= 0 && nx < n && ny >= 0 && ny < m && mp[nx][ny] == cz[xb + 1])
{
if(dfs(nx,ny,i,xb + 1))
return true;
}
return false;
}

bool dy(int x,int y)
{
int nx,ny,xb = 1;
for(int i = 0;i < 8;i++)
{
nx = x + bhx[i];
ny = y + bhy[i];
if(nx >= 0 && nx < n && ny >= 0 && ny < m && mp[nx][ny] == cz[1])
{
flag = 0;
dfs(nx,ny,i,xb);
if(flag)
{
printf("%d %d\n",x + 1,y + 1);
return true;
}
}
}
return false;
}

int main()
{
int t,k;
scanf("%d",&t);
while(t--)
{
scanf("%d%d",&n,&m);
for(int i = 0;i < n;i++)
scanf("%s",mp[i]);
for(int i = 0;i < n;i++)
{
for(int j = 0;j < m;j++)
mp[i][j] = tolower(mp[i][j]);
}
scanf("%d",&k);
while(k--)
{
scanf("%s",cz);
int len = strlen(cz);

for(int i = 0;i < len;i++)
cz[i] = tolower(cz[i]);
for(int i = 0;i < n;i++)
{
int j;
for(j = 0;j < m;j++)
{
if(mp[i][j] == cz[0])
{
if(len == 1)
{
printf("%d %d\n",i + 1,j + 1);
break;
}
else if(dy(i,j))
break;
}
}
if(j < m)
break;
}
}
if(t != 0)
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: 
相关文章推荐