您的位置:首页 > 其它

hdu 1016 Prime Ring Problem(dfs)

2014-11-27 13:08 387 查看


Prime Ring Problem

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 28196 Accepted Submission(s): 12556



Problem Description

A ring is compose of n circles as shown in diagram. Put natural number 1, 2, ..., n into each circle separately, and the sum of numbers in two adjacent circles should be a prime.

Note: the number of first circle should always be 1.



Input

n (0 < n < 20).

Output

The output format is shown as sample below. Each row represents a series of circle numbers in the ring beginning from 1 clockwisely and anticlockwisely. The order of numbers must satisfy the above requirements. Print solutions in lexicographical order.

You are to write a program that completes above process.

Print a blank line after each case.

Sample Input

6
8


Sample Output

Case 1:
1 4 3 2 5 6
1 6 5 2 3 4

Case 2:
1 2 3 8 5 6 7 4
1 2 5 8 3 4 7 6
1 4 7 6 5 8 3 2
1 6 7 4 3 8 5 2题目大意:给出一个小于20的数n,从1到n连成一个环,满足任意两个数之和都是素数
,输出所有情况。
思路:dfs深搜算法,刚开始接触,还是递归的使用,深度搜索。,不过Bfs也可以,正在学习
2014,11,17
#include<stdio.h>
#include<string.h>
int v[23],b[23],n;
int prime[]={1,0,0,0,1,0,1,0,1,1,1,0,1,0,1,1,1,0,1,0,1,1,1,0};
void dfs(int x,int y){//dfs搜索算法
int i;
if(y==n&&prime[b
+1]==0){
printf("1");
for(i=2;i<=n;i++)
printf(" %d",b[i]);
puts("");
return;
}
else {
for(i=2;i<=n;i++){
if(prime[x+i]==0&&v[i]==0){
b[y+1]=i;
v[i]=1;
dfs(i,y+1);//递归调用
v[i]=0;
}
}
}
}
int main(){
int k=1;
while(scanf("%d",&n)==1){
memset(b,0,sizeof(b));
memset(v,0,sizeof(v));
printf("Case %d:\n",k++);
b[1]=1;//每组数都是从1开始
v[1]=1;
dfs(1,1);
puts("");
}
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: