您的位置:首页 > 其它

hdu 4771 Stealing Harry Potter's Precious(BFS+DFS)

2014-11-19 09:50 120 查看


Stealing Harry Potter's Precious

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 1868 Accepted Submission(s): 871



Problem Description

  Harry Potter has some precious. For example, his invisible robe, his wand and his owl. When Hogwarts school is in holiday, Harry Potter has to go back to uncle Vernon's home. But he can't bring his precious with him. As you know, uncle Vernon never allows
such magic things in his house. So Harry has to deposit his precious in the Gringotts Wizarding Bank which is owned by some goblins. The bank can be considered as a N × M grid consisting of N × M rooms. Each room has a coordinate. The coordinates of the upper-left
room is (1,1) , the down-right room is (N,M) and the room below the upper-left room is (2,1)..... A 3×4 bank grid is shown below:



  Some rooms are indestructible and some rooms are vulnerable. Goblins always care more about their own safety than their customers' properties, so they live in the indestructible rooms and put customers' properties in vulnerable rooms. Harry Potter's precious
are also put in some vulnerable rooms. Dudely wants to steal Harry's things this holiday. He gets the most advanced drilling machine from his father, uncle Vernon, and drills into the bank. But he can only pass though the vulnerable rooms. He can't access
the indestructible rooms. He starts from a certain vulnerable room, and then moves in four directions: north, east, south and west. Dudely knows where Harry's precious are. He wants to collect all Harry's precious by as less steps as possible. Moving from
one room to another adjacent room is called a 'step'. Dudely doesn't want to get out of the bank before he collects all Harry's things. Dudely is stupid.He pay you $1,000,000 to figure out at least how many steps he must take to get all Harry's precious.

Input

  There are several test cases.

  In each test cases:

  The first line are two integers N and M, meaning that the bank is a N × M grid(0<N,M <= 100).

  Then a N×M matrix follows. Each element is a letter standing for a room. '#' means a indestructible room, '.' means a vulnerable room, and the only '@' means the vulnerable room from which Dudely starts to move.

  The next line is an integer K ( 0 < K <= 4), indicating there are K Harry Potter's precious in the bank.

  In next K lines, each line describes the position of a Harry Potter's precious by two integers X and Y, meaning that there is a precious in room (X,Y).

  The input ends with N = 0 and M = 0

Output

  For each test case, print the minimum number of steps Dudely must take. If Dudely can't get all Harry's things, print -1.

Sample Input

2 3
##@
#.#
1
2 2
4 4
#@##
....
####
....
2
2 1
2 4
0 0


Sample Output

-1
5


题意:让你从@点出发然后去k个宝藏点,输出到达这些点的最小步数,如果走不通就输出-1。

做法:先BFS出各个宝藏点以及起点之间的最短走法,然后DFS这些点求出最小值。

#include <iostream>
#include <cstdio>
#include <climits>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <vector>
#include <queue>
#include <map>
#include<stack>
#include <set>
#include <algorithm>
#include<ctime>
#define esp 1e-6
#define LL long long
#define inf 0x0f0f0f0f
using namespace std;
int dx[4] = {0,0,-1,1};
int dy[4] = {-1,1,0,0};
char Map[140][140];
int vis[140][140], L, R, ans,k;
int num[105][105];
int v[105];
struct node
{
int x, y;
int time;
}st[10];

bool check(int x, int y)
{
if(x >= 1 && x <= L && y >= 1 && y <= R )
return true;
return false;
}
int BFS(int ss,int ed)
{
queue<node> q;
memset(vis,0,sizeof(vis));
int x, y, z, t, i;
node aa;
aa.x=st[ss].x;
aa.y=st[ss].y;
vis[aa.x][aa.y]=1;
aa.time=0;
q.push(aa);
while(!q.empty())
{
node tmp = q.front();
q.pop();
x = tmp.x;
y = tmp.y;
t = tmp.time;
for(i = 0; i < 4; i++)
{
int nx = x + dx[i];
int ny = y + dy[i];
if(!vis[nx][ny] && Map[nx][ny] != '#' && check(nx,ny))
{
if(nx == st[ed].x && ny == st[ed].y)
return t+1;
vis[nx][ny] = 1;
node temp;
temp.x = nx;
temp.y = ny;
temp.time = t + 1;
q.push(temp);
}
}
}
return -1;
}
void DFS(int x,int bs,int sum)
{
if(sum==k)
{
if(bs<ans)
ans=bs;
}
int i;
v[x]=1;
for(i=1;i<=k;i++)
{
if(v[i]==0&&num[x][i]!=-1)
{
DFS(i,bs+num[x][i],sum+1);
v[i]=0;
}
}
}
int main()
{
int n,m;
int i,j;
int xx,yy;
while(scanf("%d%d",&n,&m)!=EOF)
{
if(n==0&&m==0)
break;
ans=inf;
memset(num,-1,sizeof(num));
memset(v,0,sizeof(v));
L=n;
R=m;
for(i=1;i<=n;i++)
{
getchar();
for(j=1;j<=m;j++)
{
scanf("%c",&Map[i][j]);
if(Map[i][j]=='@')
{
xx=i;
yy=j;
}
}
}
st[0].x=xx;
st[0].y=yy;
st[0].time=0;
scanf("%d",&k);
for(i=1;i<=k;i++)
{
int u,v;
scanf("%d%d",&u,&v);
st[i].x=u;
st[i].y=v;
st[i].time=0;
}
int flag;
flag=1;
for(i=0;i<=k;i++)
num[i][i]=0;
for(i=0;i<=k;i++)
for(j=0;j<=k;j++)
{
if(num[i][j]==-1&&flag==1)
{
num[i][j]=BFS(i,j);
num[j][i]=num[i][j];
if(num[i][j]==-1)
{
flag=0;
break;
}
}
}
DFS(0,0,0);
if(flag==1)
printf("%d\n",ans);
else
printf("-1\n");
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: