您的位置:首页 > 其它

简单计算器(杭电1237)(栈的运用)

2014-11-05 12:38 155 查看


简单计算器

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 12594 Accepted Submission(s): 4139



Problem Description

读入一个只包含 +, -, *, / 的非负整数计算表达式,计算该表达式的值。



Input

测试输入包含若干测试用例,每个测试用例占一行,每行不超过200个字符,整数和运算符之间用一个空格分隔。没有非法表达式。当一行中只有0时输入结束,相应的结果不要输出。



Output

对每个测试用例输出1行,即该表达式的值,精确到小数点后2位。



Sample Input

1 + 2
4 + 2 * 5 - 7 / 11
0




Sample Output

3.00
13.36/*运用栈的性质,技巧性强。 
*/
#include<stdio.h>
#include<string.h>
int main()
{
	double a[200],sum,t,b;
	int len;
	char c;
	while(scanf("%lf",&b))
	{
		len=0;
		memset(a,0,sizeof(a));
		a[len]=b;
	    c=getchar();
	    if(b==0&&c=='\n') //当输入0的话程序结束。 
		{
		   break;
	    }
	    while(1)
	    {
	    	scanf("%c %lf",&c,&t);
	    	if(c=='*')
	    	    a[len]*=t;
	    	else if(c=='/')
	    	    a[len]/=t;
	    	else if(c=='+')
	    	    a[++len]=t;
	    	else 
	    	    a[++len]=-t;
	    	if(getchar()=='\n')  //用来判断最后的元素,循环终止的判断。 
			{
			    break;
			}	
	    }
	    for(sum=0;len>=0;len--)
	    {
	    	sum+=a[len];
	    }
	    printf("%.2lf\n",sum);
	} 
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: