您的位置:首页 > 其它

Football - POJ 3071 概率dp

2014-11-04 12:52 302 查看
Football

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 3203Accepted: 1631
Description

Consider a single-elimination football tournament involving 2n teams, denoted 1, 2, …, 2n. In each round of the tournament, all teams still in the tournament are placed in a list in order of increasing index. Then,
the first team in the list plays the second team, the third team plays the fourth team, etc. The winners of these matches advance to the next round, and the losers are eliminated. After n rounds, only one team remains undefeated; this team is declared
the winner.

Given a matrix P = [pij] such that pij is the probability that team i will beat team j in a match determine which team is most likely to win the tournament.

Input

The input test file will contain multiple test cases. Each test case will begin with a single line containing n (1 ≤ n ≤ 7). The next 2n lines each contain 2n values; here, the jth value
on the ith line represents pij. The matrix P will satisfy the constraints that pij = 1.0 − pji for all i ≠ j, and pii = 0.0 for all i.
The end-of-file is denoted by a single line containing the number −1. Note that each of the matrix entries in this problem is given as a floating-point value. To avoid precision problems, make sure that you use either the
double
data type instead
of
float
.

Output

The output file should contain a single line for each test case indicating the number of the team most likely to win. To prevent floating-point precision issues, it is guaranteed that the difference in win probability for the top two teams will be at least
0.01.

Sample Input
2
0.0 0.1 0.2 0.3
0.9 0.0 0.4 0.5
0.8 0.6 0.0 0.6
0.7 0.5 0.4 0.0
-1

Sample Output
2

Hint

In the test case above, teams 1 and 2 and teams 3 and 4 play against each other in the first round; the winners of each match then play to determine the winner of the tournament. The probability that team 2 wins the tournament in this
case is:

P(2 wins) = P(2 beats 1)P(3 beats 4)P(2 beats 3) + P(2 beats 1)P(4 beats 3)P(2 beats 4)

= p21p34p23 + p21p43p24

= 0.9 · 0.6 · 0.4 + 0.9 · 0.4 · 0.5 = 0.396.
The next most likely team to win is team 3, with a 0.372 probability of winning the tournament.

题意:给你2的n次方的人数,每次相邻的两个人比赛,然后输的淘汰掉,继续比赛。每个人都有赢的可能性,问最后谁赢的可能性最大。

思路:在每轮中,每个人赢的概率就是他在上一局赢的概率乘以他可能在这局遇到的所有人的概率和。

AC代码如下:

#include<cstdio>
#include<cstring>
using namespace std;
double f[130][130],dp[10][130];
int main()
{
    int n,m,i,j,k,l,r,l2,r2,ans;
    double ret;
    while(~scanf("%d",&n) && n!=-1)
    {
        m=1<<n;
        for(i=1;i<=m;i++)
           for(j=1;j<=m;j++)
              scanf("%lf",&f[i][j]);
        memset(dp,0,sizeof(dp));
        for(i=1;i<=m;i++)
           dp[0][i]=1;
        for(i=1;i<=n;i++)
           for(j=1;j<=m;j++)
           {
               k=1<<i;
               l=(j-1)/k*k+1;
               r=l+k-1;
               k=1<<(i-1);
               l2=(j-1)/k*k+1;
               r2=l2+k-1;
               for(k=l;k<=r;k++)
                  if(k<l2 || k>r2)
                  {
                      dp[i][j]+=dp[i-1][k]*f[j][k]*dp[i-1][j];
                  }
           }
        ret=0;
        ans=0;
        for(i=1;i<=m;i++)
           if(dp
[i]>ret)
           {
               ret=dp
[i];
               ans=i;
           }
        printf("%d\n",ans);
    }
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: