您的位置:首页 > 其它

hdoj 1073 Online Judge(输入格式控制)

2014-10-31 16:47 267 查看

Online Judge

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 5409 Accepted Submission(s): 2065



Problem Description
Ignatius is building an Online Judge, now he has worked out all the problems except the Judge System. The system has to read data from correct output file and user's result file, then the system compare the two files. If the two files
are absolutly same, then the Judge System return "Accepted", else if the only differences between the two files are spaces(' '), tabs('\t'), or enters('\n'), the Judge System should return "Presentation Error", else the system will return "Wrong Answer".

Given the data of correct output file and the data of user's result file, your task is to determine which result the Judge System will return.



Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.

Each test case has two parts, the data of correct output file and the data of the user's result file. Both of them are starts with a single line contains a string "START" and end with a single line contains a string "END", these two strings are not the data.
In other words, the data is between the two strings. The data will at most 5000 characters.



Output
For each test cases, you should output the the result Judge System should return.



Sample Input
4
START
1 + 2 = 3
END
START
1+2=3
END
START
1 + 2 = 3
END
START
1 + 2 = 3

END
START
1 + 2 = 3
END
START
1 + 2 = 4
END
START
1 + 2 = 3
END
START
1	+	2	=	3
END




Sample Output
Presentation Error
Presentation Error
Wrong Answer
Presentation Error




Author
Ignatius.L
/*
格式控制,周赛的时候没做出来
Time:2014-10-31 16:46
*/
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define MAX 5050
char s1[MAX],s2[MAX];
void Input(char *str){
	char temp[MAX];
	while(gets(temp)&&strcmp(temp,"END")){
		if(strlen(temp))
			strcat(str,temp);
		else
			strcat(str,"\n");
	}
}
void delChar(char *str){
	int i,k;k=0;
	char temp[MAX];
	for(i=0;str[i];i++){
		if(str[i]!=' '&&str[i]!='\t'&&str[i]!='\n')
			temp[k++]=str[i];
	}
	temp[k]='\0';
	strcpy(str,temp);
}
int main(){
	int n;
	scanf("%d",&n);
	while(n--){
		memset(s1,0,sizeof(s1));
		memset(s2,0,sizeof(s2));
		Input(s1);
		Input(s2);
		if(strcmp(s1,s2)==0){puts("Accepted");continue;}
		delChar(s1);delChar(s2);
		if(strcmp(s1,s2)==0)puts("Presentation Error");
		else puts("Wrong Answer");
	}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: