您的位置:首页 > 其它

poj 2184 Cow Exhibition 01背包变形

2014-10-23 19:57 316 查看
点击打开链接链接

Cow Exhibition

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 9288Accepted: 3551
Description

"Fat and docile, big and dumb, they look so stupid, they aren't much

fun..."

- Cows with Guns by Dana Lyons

The cows want to prove to the public that they are both smart and fun. In order to do this, Bessie has organized an exhibition that will be put on by the cows. She has given each of the N (1 <= N <= 100) cows a thorough interview and determined two values for
each cow: the smartness Si (-1000 <= Si <= 1000) of the cow and the funness Fi (-1000 <= Fi <= 1000) of the cow.

Bessie must choose which cows she wants to bring to her exhibition. She believes that the total smartness TS of the group is the sum of the Si's and, likewise, the total funness TF of the group is the sum of the Fi's. Bessie wants to maximize the sum of TS
and TF, but she also wants both of these values to be non-negative (since she must also show that the cows are well-rounded; a negative TS or TF would ruin this). Help Bessie maximize the sum of TS and TF without letting either of these values become negative.

Input

* Line 1: A single integer N, the number of cows

* Lines 2..N+1: Two space-separated integers Si and Fi, respectively the smartness and funness for each cow.

Output

* Line 1: One integer: the optimal sum of TS and TF such that both TS and TF are non-negative. If no subset of the cows has non-negative TS and non- negative TF, print 0.

Sample Input
5
-5 7
8 -6
6 -3
2 1
-8 -5

Sample Output
8

Hint

OUTPUT DETAILS:

Bessie chooses cows 1, 3, and 4, giving values of TS = -5+6+2 = 3 and TF

= 7-3+1 = 5, so 3+5 = 8. Note that adding cow 2 would improve the value

of TS+TF to 10, but the new value of TF would be negative, so it is not

allowed.

给出每头牛的s和f 要挑出几头牛

要求ts和tf的和最大

切ts和tf不能为负

dp[i]代表ts-100000为i时tf的最大值

因为有负数 所以以100000为起点 i<100000时代表ts<0

#include<cstdio>
#include<cstring>
#define INF 0x3f3f3f3f
int maxn(int a,int b)
{
    return a>b?a:b;
}
int dp[211111];
int main()
{
    int n,i,j,s[110],f[110];
    while(scanf("%d",&n)!=EOF)
    {
        for(i=0;i<n;i++)
            scanf("%d %d",&s[i],&f[i]);
        for(i=0;i<=200000;i++)
            dp[i]=-INF;
        dp[100000]=0;
        for(i=0;i<n;i++)
        {
            if(s[i]>=0)
            {
                for(j=200000;j>=s[i];j--)
                {
                    dp[j]=maxn(dp[j],dp[j-s[i]]+f[i]);
                }
            }
            else
            {
                for(j=s[i];j<=200000+s[i];j++)
                {
                    dp[j]=maxn(dp[j],dp[j-s[i]]+f[i]);
                }
            }
        }
        int ans=0;
        for(i=100000;i<=200000;i++)
        {
            if(dp[i]>0)
            ans=maxn(ans,i-100000+dp[i]);
        }
        printf("%d\n",ans);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: