您的位置:首页 > 其它

二分|hash(找正方形)poj2002

2014-09-29 19:37 253 查看
Language:
Default

Squares

Time Limit: 3500MS

Memory Limit: 65536K

Total Submissions: 16255

Accepted: 6181

Description

A square is a 4-sided polygon whose sides have equal length and adjacent sides form 90-degree angles. It is also a polygon such that rotating about its centre by 90 degrees gives the same polygon. It is not the only polygon with the latter property, however,
as a regular octagon also has this property.

So we all know what a square looks like, but can we find all possible squares that can be formed from a set of stars in a night sky? To make the problem easier, we will assume that the night sky is a 2-dimensional plane, and each star is specified by its x
and y coordinates.

Input

The input consists of a number of test cases. Each test case starts with the integer n (1 <= n <= 1000) indicating the number of points to follow. Each of the next n lines specify the x and y coordinates (two integers) of each point. You may assume that the
points are distinct and the magnitudes of the coordinates are less than 20000. The input is terminated when n = 0.

Output

For each test case, print on a line the number of squares one can form from the given stars.

Sample Input
4
1 0
0 1
1 1
0 0
9
0 0
1 0
2 0
0 2
1 2
2 2
0 1
1 1
2 1
4
-2 5
3 7
0 0
5 2
0


Sample Output
1
6
1


先把点从左下角到右上角排序,然后枚举两个点,利用三角形相似算出另外两个点,看是不是存在,可以用二分,也可以hash,然后答案除以2,因为我这样算,一个正方形会被算两次

二分代码:

#include<iostream>
#include<cstdio>
#include<string>
#include<cstring>
#include<vector>
#include<cmath>
#include<queue>
#include<stack>
#include<map>
#include<set>
#include<algorithm>
using namespace std;
const int maxn=1010;
struct P
{
    int x,y;
    bool operator<(const P &a)const
    {
        if(x==a.x)return y<a.y;
        return x<a.x;
    }
}p[maxn];
int N;
int main()
{
    while(scanf("%d",&N)!=EOF,N)
    {
        for(int i=1;i<=N;i++)scanf("%d%d",&p[i].x,&p[i].y);
        sort(p+1,p+1+N);
        int cnt=0;
        for(int i=1;i<=N;i++)
        {
            for(int j=i+1;j<=N;j++)
            {
                P tmp;
                tmp.x=p[i].x-p[j].y+p[i].y;
                tmp.y=p[i].y+p[j].x-p[i].x;
                if(!binary_search(p+1,p+1+N,tmp))continue;
                tmp.x=p[j].x-p[j].y+p[i].y;
                tmp.y=p[j].y+p[j].x-p[i].x;
                if(!binary_search(p+1,p+1+N,tmp))continue;
                cnt++;
            }
        }
        printf("%d\n",cnt/2);
    }
    return 0;
}


hash:

#include<iostream>
#include<cstdio>
#include<string>
#include<cstring>
#include<vector>
#include<cmath>
#include<queue>
#include<stack>
#include<map>
#include<set>
#include<algorithm>
using namespace std;
const int maxn=1010;
const int MOD=21997;
int hash[MOD],next[MOD];
int N;
struct P
{
    int x,y;
    bool operator<(const P &a)const
    {
        if(x==a.x)return y<a.y;
        return x<a.x;
    }
}p[maxn];
void insert()
{
    memset(hash,-1,sizeof(hash));
    for(int i=1;i<=N;i++)
    {
        int tmp=(p[i].x*p[i].x+p[i].y*p[i].y)%MOD;
        next[i]=hash[tmp];
        hash[tmp]=i;
    }
}
bool find(P tmp)
{
    int key=(tmp.x*tmp.x+tmp.y*tmp.y)%MOD;
    for(int i=hash[key];i!=-1;i=next[i])
    {
        if(tmp.x==p[i].x&&tmp.y==p[i].y)return true;
    }
    return false;
}
int main()
{
    while(scanf("%d",&N)!=EOF,N)
    {
        for(int i=1;i<=N;i++)scanf("%d%d",&p[i].x,&p[i].y);
        sort(p+1,p+1+N);
        insert();
        int cnt=0;
        for(int i=1;i<=N;i++)
        {
            for(int j=i+1;j<=N;j++)
            {
                P tmp;
                tmp.x=p[i].x-p[j].y+p[i].y;
                tmp.y=p[i].y+p[j].x-p[i].x;
                if(!find(tmp))continue;
                tmp.x=p[j].x-p[j].y+p[i].y;
                tmp.y=p[j].y+p[j].x-p[i].x;
                if(!find(tmp))continue;
                cnt++;
            }
        }
        printf("%d\n",cnt/2);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: