您的位置:首页 > 其它

POJ 1064 Cable master(很好玩的二分搜索)

2014-09-24 21:25 357 查看
Cable master

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 24292Accepted: 5200
Description

Inhabitants of the Wonderland have decided to hold a regional programming contest. The Judging Committee has volunteered and has promised to organize the most honest contest ever. It was decided to connect computers for the contestants using a "star" topology
- i.e. connect them all to a single central hub. To organize a truly honest contest, the Head of the Judging Committee has decreed to place all contestants evenly around the hub on an equal distance from it.

To buy network cables, the Judging Committee has contacted a local network solutions provider with a request to sell for them a specified number of cables with equal lengths. The Judging Committee wants the cables to be as long as possible to sit contestants
as far from each other as possible.

The Cable Master of the company was assigned to the task. He knows the length of each cable in the stock up to a centimeter,and he can cut them with a centimeter precision being told the length of the pieces he must cut. However, this time, the length is not
known and the Cable Master is completely puzzled.

You are to help the Cable Master, by writing a program that will determine the maximal possible length of a cable piece that can be cut from the cables in the stock, to get the specified number of pieces.
Input

The first line of the input file contains two integer numb ers N and K, separated by a space. N (1 = N = 10000) is the number of cables in the stock, and K (1 = K = 10000) is the number of requested pieces. The first line is followed by N lines with one number
per line, that specify the length of each cable in the stock in meters. All cables are at least 1 meter and at most 100 kilometers in length. All lengths in the input file are written with a centimeter precision, with exactly two digits after a decimal point.
Output

Write to the output file the maximal length (in meters) of the pieces that Cable Master may cut from the cables in the stock to get the requested number of pieces. The number must be written with a centimeter precision, with exactly two digits after a decimal
point.

If it is not possible to cut the requested number of pieces each one being at least one centimeter long, then the output file must contain the single number "0.00" (without quotes).
Sample Input
4 11
8.02
7.43
4.57
5.39

Sample Output
2.00


题意:有N条绳子,分别长Li,现将N条绳子分成K条长度相等绳子,求这K条绳子的最大可分割长度。

分析:想了一下,感觉一般方法都不太好用,关键点在于找出可以满足K分割且临界于绳子总长的的点,因此考到使用二分搜索,以100次二分精准查找到可行值,,,,POJ上C++可以通过,G++超时,貌似讨论区没人通过G++。。。。

#include<iostream>
#include<cstdio>
#include<cmath>
const int MAXN=10000;
const long INF=100000;
double L[MAXN];
int N,K;
int Tdfs(double x)
{
int num=0;
for(int i=0;i<N;i++)
num+=(int)(L[i]/x);
return num>=K;
}
int main()
{
int i;
double lb=0,ub=INF,mid;
while(std::cin>>N>>K)
{
for(i=0;i<N;i++)
std::cin>>L[i];
for(i=0;i<100;i++)
{
mid=(lb+ub)/2;
if(Tdfs(mid))
lb=mid;
else
ub=mid;
}
printf("%.2f\n",floor(ub*100)/100);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: