您的位置:首页 > 其它

hdu 1394 Minimum Inversion Number(树状数组,线段树)

2014-08-27 14:57 399 查看


Minimum Inversion Number

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 11121 Accepted Submission(s): 6842



Problem Description

The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, ..., an-1, an (where m = 0 - the initial seqence)

a2, a3, ..., an, a1 (where m = 1)

a3, a4, ..., an, a1, a2 (where m = 2)

...

an, a1, a2, ..., an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.

Input

The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.

Output

For each case, output the minimum inversion number on a single line.

Sample Input

10
1 3 6 9 0 8 5 7 4 2


Sample Output

16


求最小逆序数,因为是0到n的排列,那么如果把第一个数放到最后,对于这个数列,逆序数是减少a[i],而增加n-1-a[i]的。因为a[0]后面肯定有a[0]个比它小的数,n-1-a[0]个比它大的,每次把a[i]个当a[0],就是减少a[i],增加n-1-a[i]。

树状数组:

//time 31ms
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
#include <vector>
using namespace std;
const int maxn=10000+100;
int a[maxn];
int b[maxn];
int low(int k)
{
return k&(-k);
}
void update(int k,int v)
{
while(k<maxn)
{
a[k]+=v;
k+=low(k);
}
}
int getsum(int k)
{
int ans=0;
while(k>0)
{
ans+=a[k];
k-=low(k);
}
return ans;
}
int main()
{
int n;
while(~scanf("%d",&n))
{
int ans=0;
memset(a,0,sizeof(a));
for(int i=1;i<=n;i++)
{
scanf("%d",&b[i]);
b[i]++;//树状数组统计不到0,会陷入死循环
ans+=getsum(maxn-1)-getsum(b[i]);//前面的比它大的
update(b[i],1);
}
int Min=ans;
for(int i=1;i<=n;i++)
{
ans+=n-b[i]+1-b[i];
if(ans<Min)
Min=ans;
}
printf("%d\n",Min);
}
return 0;
}


线段树:
//46ms
#include <iostream>
#include <cstdio>
#include <algorithm>
#include <cstring>
using namespace std;
const int maxn=100000+1000;
int a[maxn];
struct node
{
int l;
int r;
int sum;
}edge[3*maxn];
void build(int i,int l,int r)
{
edge[i].l=l;
edge[i].r=r;
if(l==r)
{
edge[i].sum=0;
return;
}
int mid=(l+r)>>1;
build(i<<1,l,mid);
build(i<<1|1,mid+1,r);
edge[i].sum=0;
}
void add(int i,int k,int v)
{
edge[i].sum+=v;
if(edge[i].l==edge[i].r)
{
return;
}
int mid=(edge[i].l+edge[i].r)>>1;
if(mid>=k)
{
add(i<<1,k,v);
}
else
{
add(i<<1|1,k,v);
}
}
int sum(int i,int l,int r)
{
if(edge[i].l==l&&edge[i].r==r)
return edge[i].sum;
int mid=(edge[i].l+edge[i].r)>>1;
if(r<=mid)
{
return sum(i<<1,l,r);
}
else if(l>mid)  return sum((i<<1)|1,l,r);
else return sum(i<<1,l,mid)+sum((i<<1)|1,mid+1,r);
}
int main()
{
int n;
while(scanf("%d",&n)!=EOF)
{
int ans=0;
build(1,0,n-1);
for(int i=0;i<n;i++)
scanf("%d",&a[i]);
for(int i=0;i<n;i++)
{
ans+=sum(1,a[i],n-1);
add(1,a[i],1);
}
int Min=ans;
for(int i=0;i<n;i++)
{
ans+=n-a[i]-a[i]-1;
if(ans<Min)Min=ans;
}
printf("%d\n",Min);
}
return 0;
}


}

return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: