您的位置:首页 > 其它

hdu1102 Constructing Roads (简单最小生成树Prim算法)

2014-08-23 14:27 316 查看
[align=left]Problem Description[/align]
There are N villages, which are numbered from 1 to N, and you should build some roads such that every two villages can connect to each other. We say two village A and B are connected, if and only if there is a road between A and B, or there exists a village C such that there is a road between A and C, and C and B are connected.

We know that there are already some
roads between some villages and your job is the build some roads such that all
the villages are connect and the length of all the roads built is
minimum.

[align=left]Input[/align]
The first line is an integer N (3 <= N <= 100),
which is the number of villages. Then come N lines, the i-th of which contains N
integers, and the j-th of these N integers is the distance (the distance should
be an integer within [1, 1000]) between village i and village j.

Then
there is an integer Q (0 <= Q <= N * (N + 1) / 2). Then come Q lines, each
line contains two integers a and b (1 <= a < b <= N), which means the
road between village a and village b has been built.

[align=left]Output[/align]
You should output a line contains an integer, which is
the length of all the roads to be built such that all the villages are
connected, and this value is minimum.

[align=left]Sample Input[/align]

3

0 990 692
990 0 179

692 179 0

1

1 2

[align=left]Sample Output[/align]

179

很简单的一个最小生成树 题意也很简单 看完直接AC了 好开心O(∩_∩)O~~

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>

using namespace std;

#define inf 99999999

int map[105][105],path,node[105],vis[105],n;

void Prim()
{
int ans=1;
vis[1]=1;
node[1]=0;
for(int k=1;k<=n;k++)
{
int minn=inf;
for(int i=1;i<=n;i++)
if(!vis[i]&&minn>node[i])
{
minn=node[i];
ans=i;
}
vis[ans]=1;
path+=node[ans];

for(int i=1;i<=n;i++)
{
if(!vis[i]&&node[i]>map[ans][i])
node[i]=map[ans][i];
}
}
}

int main()
{
while(cin>>n)
{
for(int i=1;i<=n;i++)
{
node[i]=inf;vis[i]=0;
for(int j=1;j<=n;j++)
cin>>map[i][j];
}
int m;
cin>>m;
while(m--)
{
int a,b;
cin>>a>>b;
map[a][b]=map[b][a]=0;
}
path=0;
Prim();
cout<<path<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: