您的位置:首页 > 其它

POJ 1005 I Think I Need a Houseboat(水题)

2014-08-16 17:06 369 查看
I Think I Need a Houseboat

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 86746Accepted: 37616
Description

Fred Mapper is considering purchasing some land in Louisiana to build his house on. In the process of investigating the land, he learned that the state of Louisiana is actually shrinking by 50 square miles each year, due to erosion caused by the Mississippi
River. Since Fred is hoping to live in this house the rest of his life, he needs to know if his land is going to be lost to erosion.

After doing more research, Fred has learned that the land that is being lost forms a semicircle. This semicircle is part of a circle centered at (0,0), with the line that bisects the circle being the X axis. Locations below the X axis are in the water. The
semicircle has an area of 0 at the beginning of year 1. (Semicircle illustrated in the Figure.)



Input

The first line of input will be a positive integer indicating how many data sets will be included (N). Each of the next N lines will contain the X and Y Cartesian coordinates of the land Fred is considering. These will be floating point numbers measured in
miles. The Y coordinate will be non-negative. (0,0) will not be given.
Output

For each data set, a single line of output should appear. This line should take the form of: “Property N: This property will begin eroding in year Z.” Where N is the data set (counting from 1), and Z is the first year (start from 1) this property will be within
the semicircle AT THE END OF YEAR Z. Z must be an integer. After the last data set, this should print out “END OF OUTPUT.”
Sample Input
2
1.0 1.0
25.0 0.0

Sample Output
Property 1: This property will begin eroding in year 1.
Property 2: This property will begin eroding in year 20.
END OF OUTPUT.
题意:根据上图中的坐标,土地从(0,0)出开始侵蚀掉,每年50个平方单位,现在给你个坐标(x,y)求从(0,0)处开始多少年能侵蚀到所给的坐标处。注意格式。
题目链接:http://poj.org/problem?id=1005
代码:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
using namespace std;

const double PI=3.1415926;

int main(){
int T;
scanf("%d",&T);
int cas=1;
while(T--){
double x,y;
scanf("%lf%lf",&x,&y);
double rr=x*x+y*y;
printf("Property %d: This property will begin eroding in year %.0f.\n",cas,(PI*rr/2)/50+0.5);
cas++;
}
printf("END OF OUTPUT.\n");
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: