您的位置:首页 > 产品设计 > UI/UE

hdu-oj 1562 Guess the number

2014-08-15 09:36 447 查看

Guess the number

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 2686    Accepted Submission(s): 2034


[align=left]Problem Description[/align]
Happy new year to everybody!

Now, I want you to guess a minimum number x betwwn 1000 and 9999 to let

(1) x % a = 0;

(2) (x+1) % b = 0;

(3) (x+2) % c = 0;

and a, b, c are integers between 1 and 100.

Given a,b,c, tell me what is the number of x ?

 Input
The number of test cases c is in the first line of input, then c test cases followed.every test contains three integers a, b, c.
 Output
For each test case your program should output one line with the minimal number x, you should remember that x is between 1000 and 9999. If there is no answer for x, output "Impossible".
 Sample Input

2
44 38 49
25 56 3

 Sample Output

Impossible
2575 题目大意:输入 a b c 找出x 使 x % a = 0; (x+1) % b = 0; (x+2) % c = 0;成立。解题思路:枚举附代码:
#include <stdio.h>
int main()
{  int i,a,b,c,k,t;
scanf("%d",&t);
while(t--){
scanf("%d%d%d",&a,&b,&c);
k=1;
for(i=1000;i<10000;i++)
if(i%a==0&&(i+1)%b==0&&(i+2)%c==0){
printf("%d\n",i);
k=0;
break;
}
if(k)
printf("Impossible\n");
}

return 0;
}


  

 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: