您的位置:首页 > 其它

HDU 1698 Just a Hook (线段树区间更新)

2014-08-13 16:16 567 查看
[align=left]Problem Description[/align]
In the game of DotA, Pudge’s meat hook is actually the most horrible thing for most of the heroes. The hook is made up of several consecutive metallic sticks which are of the same length.



Now Pudge wants to do some operations on the hook.

Let us number the consecutive metallic sticks of the hook from 1 to N. For each operation, Pudge can change the consecutive metallic sticks, numbered from X to Y, into cupreous sticks, silver sticks or golden sticks.

The total value of the hook is calculated as the sum of values of N metallic sticks. More precisely, the value for each kind of stick is calculated as follows:

For each cupreous stick, the value is 1.

For each silver stick, the value is 2.

For each golden stick, the value is 3.

Pudge wants to know the total value of the hook after performing the operations.

You may consider the original hook is made up of cupreous sticks.

[align=left]Input[/align]
The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 10 cases.

For each case, the first line contains an integer N, 1<=N<=100,000, which is the number of the sticks of Pudge’s meat hook and the second line contains an integer Q, 0<=Q<=100,000, which is the number of the operations.

Next Q lines, each line contains three integers X, Y, 1<=X<=Y<=N, Z, 1<=Z<=3, which defines an operation: change the sticks numbered from X to Y into the metal kind Z, where Z=1 represents the cupreous kind, Z=2 represents the silver kind and Z=3 represents
the golden kind.

[align=left]Output[/align]
For each case, print a number in a line representing the total value of the hook after the operations. Use the format in the example.

[align=left]Sample Input[/align]

1
10
2
1 5 2
5 9 3


[align=left]Sample Output[/align]

Case 1: The total value of the hook is 24.


线段树区间更新 裸题,以后写线段树的风格大概就是这样了。。深受NotOlnySccess的影响,风格都是模仿他写的。

#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <math.h>
#include <ctype.h>
#define lson o << 1, l, m
#define rson o << 1|1, m+1, r
using namespace std;
typedef long long LL;
const int MAX = 0x3f3f3f3f;
const int maxn = 100010;
int t, n, q, a, b, c;
int sum[maxn<<2], tt[maxn<<2];
void up(int o) {
sum[o] = sum[o<<1] + sum[o<<1|1];
}
void down(int o, int m) {
if(tt[o]) {
tt[o<<1] = tt[o<<1|1] = tt[o];
sum[o<<1] = tt[o]*( m - (m>>1) );
sum[o<<1|1] = tt[o]*(m>>1);
tt[o] = 0;
}
}
void build(int o, int l, int r) {
if(l == r) {
sum[o] = 1;
return ;
}
int m = (l+r) >> 1;
build(lson);
build(rson);
up(o);
}
void update(int o, int l, int r) {
if(a <= l && r <= b) {
tt[o] = c;
sum[o] = c*(r-l+1);
return ;
}
int m = (l+r) >> 1;
down(o, r-l+1);
if(a <= m) update(lson);
if(m < b ) update(rson);
up(o);
}

int main()
{
scanf("%d", &t); for(int ca = 1; ca <= t; ca++) {
scanf("%d", &n);
build(1, 1, n);
scanf("%d", &q);
memset(tt, 0, sizeof(tt));
while(q--) {
scanf("%d%d%d", &a, &b, &c);
update(1, 1, n);
}
printf("Case %d: The total value of the hook is ", ca);
printf("%d.\n", sum[1] );
}
return 0;
}



内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: