您的位置:首页 > 其它

UVA - 107 The Cat in the Hat

2014-08-10 11:37 363 查看

Background

(An homage to Theodore Seuss Geisel)

The Cat in the Hat is a nasty creature,

But the striped hat he is wearing has a rather nifty feature.

With one flick of his wrist he pops his top off.

Do you know what's inside that Cat's hat?

A bunch of small cats, each with its own striped hat.

Each little cat does the same as line three,

All except the littlest ones, who just say ``Why me?''

Because the littlest cats have to clean all the grime,

And they're tired of doing it time after time!

The Problem

A clever cat walks into a messy room which he needs to clean. Instead of doing the work alone, it decides to have its helper cats do the work. It keeps its (smaller) helper cats inside its hat. Each helper cat also has helper cats in its own hat, and so
on. Eventually, the cats reach a smallest size. These smallest cats have no additional cats in their hats. These unfortunate smallest cats have to do the cleaning.

The number of cats inside each (non-smallest) cat's hat is a constant, N. The height of these cats-in-a-hat is


times the height of the cat whose hat they are in.

The smallest cats are of height one;

these are the cats that get the work done.
All heights are positive integers.
Given the height of the initial cat and the number of worker cats (of height one), find the number of cats that are not doing any work (cats of height greater than one) and also determine the sum of all the cats' heights (the height of a stack of all cats
standing one on top of another).

The Input

The input consists of a sequence of cat-in-hat specifications. Each specification is a single line consisting of two positive integers, separated by white space. The first integer is the height of the initial cat, and the second integer is the number of
worker cats.

A pair of 0's on a line indicates the end of input.

The Output

For each input line (cat-in-hat specification), print the number of cats that are not working, followed by a space, followed by the height of the stack of cats. There should be one output line for each input line other than the ``0 0'' that terminates input.

Sample Input

216 125
5764801 1679616
0 0

Sample Output

31 671
335923 30275911

一只猫,
高度为H,戴了一个帽子,帽子里面有N只猫(N是常数,且未知),同样帽子里面的猫也戴了帽子,但是这些猫的高度变成了H / (N + 1),
会向下取整。以此递归下去,直到最后的猫的高度都为1为止。现在,给出H和高度为1的猫的数量。要求的是高度大于1的猫的数量,
以及所有猫的高度之和。
#include <cstdio>
#include <cmath>
#include <iostream>
using namespace std;
const double eps = 1e-10;

int main(){
double h,w;
while(scanf("%lf %lf",&h,&w) == 2){
if(h == 0 && w == 0)
break;
double n = 1;
while(fabs(log(h) / log(w) - log(n + 1) / log(n)) >= eps)
++n;
double k = (log(h)) / log(n + 1);
if((int)n == 1)
printf("%.0lf %.0lf\n",k,h * (n + 1) - w * n);
else
printf("%.0lf %.0lf\n",(w - 1) / (n - 1),h * (n + 1) - w * n);

}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息