您的位置:首页 > 其它

HDU1019:Least Common Multiple

2014-08-09 17:54 375 查看
[align=left]Problem Description[/align]
The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.

[align=left]Input[/align]
Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where
m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.

[align=left]Output[/align]
For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.

[align=left]Sample Input[/align]

2
3 5 7 15
6 4 10296 936 1287 792 1

[align=left]Sample Output[/align]

105
10296

最小公倍数。。

#include<stdio.h>
int gcd(int a,int b)
{
return a%b==0?b:gcd(b,a%b);
}
int main()
{
int n,t;
scanf("%d",&t);
while (t--)
{
int a=1,b;
scanf("%d",&n);
for(int i=0;i<n;i++)
{
scanf("%d",&b);
a=a/gcd(a,b)*b;
}
printf("%d\n",a);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: