您的位置:首页 > 其它

hdu 1518 Square (dfs搜索可参考poj1011)

2014-08-02 16:12 344 查看


Square

Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 8589 Accepted Submission(s): 2784



Problem Description

Given a set of sticks of various lengths, is it possible to join them end-to-end to form a square?

Input

The first line of input contains N, the number of test cases. Each test case begins with an integer 4 <= M <= 20, the number of sticks. M integers follow; each gives the length of a stick - an integer between 1 and 10,000.

Output

For each case, output a line containing "yes" if is is possible to form a square; otherwise output "no".

Sample Input

3
4 1 1 1 1
5 10 20 30 40 50
8 1 7 2 6 4 4 3 5


Sample Output

yes
no
yes


Source

University of Waterloo Local Contest 2002.09.21

#include"stdio.h"
#include"string.h"
#include"queue"
#include"vector"
#include"algorithm"
using namespace std;
#define N 25
#define max(a,b) (a>b?a:b)
int a
,n,t,mark
,sum;
bool cmp(int a,int b)
{
return a>b;
}
int dfs(int index,int len,int rest)
{
int i;
if(rest==t)
return 1;
for(i=index;i<n;i++)
{
if(!mark[i]&&a[i]<=len)
{
mark[i]=1;
if(len==a[i])
{
if(dfs(0,t,rest-a[i]))
return 1;
}
else if(dfs(i+1,len-a[i],rest-a[i]))
return 1;
mark[i]=0;  //若当前值不能满足条件,进行回溯
if(rest==sum)       //若满足此条件,则该条边不能加入任一条边
return 0;
if(len==t)   //同上
return 0;
while(a[i]==a[i+1])     //这条边不行,则和它同长的边也不行
i++;
}
}
return 0;
}
int main()
{
int T,i;
scanf("%d",&T);
while(T--)
{
scanf("%d",&n);
sum=0;
for(i=0;i<n;i++)
{
scanf("%d",&a[i]);
sum+=a[i];
}
sort(a,a+n,cmp);
if(sum%4)
printf("no\n");
else
{
memset(mark,0,sizeof(mark));
if(dfs(0,t=sum/4,sum))
printf("yes\n");
else
printf("no\n");
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: