您的位置:首页 > 其它

poj 1258 Agri-Net (最小生成树 prim)

2014-07-29 16:06 489 查看
Agri-Net

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 39499 Accepted: 16017
Description

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course. 

Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms. 

Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm. 

The distance between any two farms will not exceed 100,000. 

Input

The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines
of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.
Output

For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.
Sample Input
4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0

Sample Output
28

Source

USACO 102

最小生成树的入门题;水题一道;帮助理解一下prim算法;prim算法刚开始看的时候,没有怎么搞懂,最近又回过头来看最小生成树这一块,感觉对prim算法的理解就更深刻了;最小生成树是包含n个点的n-1条边的权值最小的一个子图;prim算法是从一个点开始,寻找与它相连的权值最小的一个点,然后把这个点也加入进来,比较这与这两个点相连的权值最小的点,更新之间的权值,后面的点以此类推;用点来寻找边;直到包含有n个点。
下面是代码;
用一个二维数组map储存图结构,用low数组记录两点之间的权值,用visit数组标志这个店是否访问;
#include <cstdio>
#include <cstring>
const int Max=0x3f3f3f3f;
const int maxn=100+10;
int map[maxn][maxn],low[maxn],visit[maxn];
int n;
int prim()
{
int pos,i,j,min,sum=0;
memset(visit,0,sizeof(visit));//初始化visit数组
visit[1]=1;//从第一个点开始
pos=1;//标记和记录这个点
for(i=1;i<=n;i++)
low[i]=map[pos][i];//用low数组记录权值
for(i=1;i<n;i++) //第一个点已经进行了,还需要进行n-1次;
{
min=Max;//把min赋初值
for(j=1;j<=n;j++)
{
if(visit[j]==0&&low[j]!=0&&low[j]<min)//比较权值的大小
{
min=low[j];
pos=j;//记录权值最小的点,下一次从这个点开始
}
}
sum+=min;//记录权值的和
visit[pos]=1;//标记访问
for(j=1;j<=n;j++)//访问下一个点
{
if(visit[j]==0&&low[j]>map[pos][j])
low[j]=map[pos][j];
}
}
return sum;
}
int main()
{
int sum,i,j;
while(scanf("%d",&n)!=EOF)
{
sum=0;
memset(map,Max,sizeof(map));
for(i=1;i<=n;i++)
for(j=1;j<=n;j++)
scanf("%d",&map[i][j]);
sum=prim();
printf("%d\n",sum);
}
return 0;
}

更新一下:
用kruskal又刷了一下这个题,属于入门题吧,kruskal写起来还是有点费劲,这道题还是用prim要简便一点,kruskal适用于稀疏图,在边比较少的时候适用,
先对边进行排序,然后用并查集判断所加入的边是否与先前的边形成回路;没有形成回路就把权值较小的那条边加入到生成树中;
下面是代码:
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
struct node
{
int u,v,cost;
};
node map[100002];
int father[102];
int n,k;
bool cmp(node a,node b)
{
return a.cost<b.cost;//按照升序排序
}
void Init()//对并查集初始化
{
for(int i=1;i<=n;i++)
father[i]=i;
}
int find_set(int x)//带状态压缩的查找
{
if(father[x]==x)
return x;
else
return father[x]=find_set(father[x]);
}
bool union_set(int x,int y)//两个集合之间的合并
{
x=find_set(x);
y=find_set(y);
if(x!=y)
{
father[y]=x;
return true;
}
else
{
return false;
}
}
int kruskal()
{
int i,mst_edge=0,sum=0;
Init();//初始化
sort(map,map+k,cmp);//排序
for(i=1;i<=k;i++)
{
if(union_set(map[i].u,map[i].v))//判断是否形成回路
{
sum+=map[i].cost;
mst_edge++;
}
}
if(mst_edge==n-1)//根据生成树的概念,最小生成树的边数应等于顶点数减一
return sum;
return mst_edge;
}
int main()
{
int i,j,w;
while(scanf("%d",&n)!=EOF)
{
k=0;
for(i=1;i<=n;i++)
for(j=1;j<=n;j++)
{
scanf("%d",&w);
if(i!=j)
{
map[k].u=i;
map[k].v=j;
map[k++].cost=w;
}
}
printf("%d\n",kruskal());
}
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: