您的位置:首页 > 其它

HDU1162 Eddy's picture 【最小生成树Prim】

2014-07-29 15:52 281 查看

Eddy's picture

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 6723    Accepted Submission(s): 3391


[align=left]Problem Description[/align]
Eddy begins to like painting pictures recently ,he is sure of himself to become a painter.Every day Eddy draws pictures in his small room, and he usually puts out his newest pictures to let his friends appreciate. but the result it
can be imagined, the friends are not interested in his picture.Eddy feels very puzzled,in order to change all friends 's view to his technical of painting pictures ,so Eddy creates a problem for the his friends of you.

Problem descriptions as follows: Given you some coordinates pionts on a drawing paper, every point links with the ink with the straight line, causes all points finally to link in the same place. How many distants does your duty discover the shortest length
which the ink draws?

 

 

[align=left]Input[/align]
The first line contains 0 < n <= 100, the number of point. For each point, a line follows; each following line contains two real numbers indicating the (x,y) coordinates of the point.

Input contains multiple test cases. Process to the end of file.

 

 

[align=left]Output[/align]
Your program prints a single real number to two decimal places: the minimum total length of ink lines that can connect all the points.

 

 

[align=left]Sample Input[/align]

3
1.0 1.0
2.0 2.0
2.0 4.0

 

 

[align=left]Sample Output[/align]

3.41

题意:给定n个点的坐标,求将这n个点连起来的最小生成树。

题解:直接套模板。

 

#include <stdio.h>
#include <math.h>
#include <string.h>
#define maxn 102

double _x[maxn], _y[maxn];
double map[maxn][maxn];
bool vis[maxn];

double cal(int i, int j)
{
double x = _x[i] - _x[j];
double y = _y[i] - _y[j];
return sqrt(x * x + y * y);
}

void Prim(int n)
{
int i, j, count = 0, u;
double len = 0, tmp;
vis[0] = 1;
while(count < n - 1){
for(i = 0, tmp = -1; i < n; ++i){
if(!vis[i]) continue;
for(j = 0; j < n; ++j)
if(!vis[j] && (map[i][j] < tmp || tmp < 0)){
tmp = map[i][j]; u = j;
}
}
if(tmp >= 0){
++count; vis[u] = 1;
len += tmp;
}
}
printf("%.2lf\n", len);
}

int main()
{
//freopen("in.txt", "r", stdin);
//freopen("out.txt", "w", stdout);
int n, i, j;
double len;
while(scanf("%d", &n) != EOF){
memset(vis, 0, sizeof(vis));
for(i = 0; i < n; ++i){
scanf("%lf%lf", _x + i, _y + i);
for(j = 0; j < i; ++j){
len = cal(i, j);
map[i][j] = map[j][i] = len;
}
}
Prim(n);
}
return 0;
}


 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  HDU1162