您的位置:首页 > 其它

hdu 1062 Text Reverse

2014-07-28 23:41 316 查看
Text Reverse

Time Limit : 2000/1000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other)

Total Submission(s) : 1 Accepted Submission(s) : 1

Font: Times New Roman | Verdana | Georgia

Font Size: ← →

Problem Description

Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.

Input

The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.

Each test case contains a single line with several words. There will be at most 1000 characters in a line.

Output

For each test case, you should output the text which is processed.

Sample Input

3

olleh !dlrow

m'I morf .udh

I ekil .mca

Sample Output

hello world!

I'm from hdu.

I like acm.

Hint

Remember to use getchar() to read '\n' after the interger T, then you may use gets() to read a line and process it.

/*

题解:

再循环中,遇到' '或'\0'暂停,记录单词开始和末尾的位置,从后向前输出,有' '输出' '

*/

#include<cstdio>

int main()

{

int n,len,i,j,k,t;

scanf("%d",&n);

getchar();

while(n--)

{

char a[1010],b[1010];

gets(a);

for(i=0,k=0,k=0; a[i]!='\0'; i++)

{

if( (a[i]!=' '&&a[i+1]==' ')||(a[i]!=' '&&a[i+1]=='\0') )

{

t=i;

for(j=t; j>=k; j--)

printf("%c",a[j]);

}

if(a[i]==' ') printf("%c",a[i]);

if(a[i]==' '&&a[i+1]!=' ') k=i+1;

}

printf("\n");

}

return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: