您的位置:首页 > 其它

poj1470-Closest Common Ancestors(LCA)

2014-07-27 16:35 369 查看
Closest Common Ancestors


Time Limit:2000MS Memory Limit:10000KB
Description

Write a program that takes as input a rooted tree and a list of pairs of vertices. For each pair (u,v) the program determines the closest common ancestor of u and v in the tree. The closest common ancestor of two nodes u and v is the node w that is an ancestor
of both u and v and has the greatest depth in the tree. A node can be its own ancestor (for example in Figure 1 the ancestors of node 2 are 2 and 5)

Input

The data set, which is read from a the std input, starts with the tree descri_ption, in the form:

nr_of_vertices

vertex:(nr_of_successors) successor1 successor2 ... successorn

...

where vertices are represented as integers from 1 to n ( n <= 900 ). The tree descri_ption is followed by a list of pairs of vertices, in the form:

nr_of_pairs

(u v) (x y)
...

The input file contents several data sets (at least one).

Note that white-spaces (tabs, spaces and line breaks) can be used freely in the input.

Output

For each common ancestor the program prints the ancestor and the number of pair for which it is an ancestor. The results are printed on the standard output on separate lines, in to the ascending order of the vertices, in the format: ancestor:times

For example, for the following tree:



Sample Input

5

5:(3) 1 4 2

1:(0)

4:(0)

2:(1) 3

3:(0)

6

(1 5) (1 4) (4 2)

(2 3)

(1 3) (4 3)

Sample Output

2:1

5:5

//查询最近的公共祖先
#include<iostream>
#include<stdio.h>
#include<vector>
#include<string.h>
#include<algorithm>
using namespace std;
vector<int> c[902];//c[x]保存x的子节点
vector<int> q[902];//q[x]保存与x相关的询问
int f[902],ans[902],visit[902],root[902];
//f保存父节点,ans保存作为询问祖先节点的次数
int find(int x)
{
	return f[x]==x?x:f[x]=find(f[x]);
}
void tarjan(int x)//LCA
{
	f[x]=x;
	for(int i=0;i<c[x].size();i++){
		tarjan(c[x][i]);
		f[c[x][i]]=x;
	}
	visit[x]=1;
	for(int k=0;k<q[x].size();k++)
		if(visit[q[x][k]]) ans[find(q[x][k])]++;
}
int main()
{
	int n,i,j,x,y,m;
	char s1[3],s2[3],s3[3];
	while(~scanf("%d",&n))
	{
		for(i=1;i<=n;i++)
		{
			visit[i]=ans[i]=root[i]=0;
			c[i].clear();q[i].clear();
		}
		for(i=1;i<=n;i++)
		{
			scanf("%d%1s%1s%d%1s",&x,s1,s2,&m,s3);
			for(j=1;j<=m;j++)
			{
				scanf("%d",&y);
				c[x].push_back(y);
				root[y]=1;
			}
		}
		scanf("%d",&m);
		for(i=1;i<=m;i++)
		{
			scanf("%1s%d%d%1s",s1,&x,&y,s2);
			q[x].push_back(y);
			q[y].push_back(x);
		}
		for(i=1;i<=n;i++)
			if(!root[i]){
				tarjan(i);break;
			}
			for(i=1;i<=n;i++)
				if(ans[i]) printf("%d:%d\n",i,ans[i]);
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: