您的位置:首页 > 其它

Can you solve this equation?(二分)

2014-07-26 22:26 176 查看
Description

Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;

Now please try your lucky.


Input

The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);


Output

For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.


Sample Input

2
100
-4




Sample Output

1.6152
No solution!




解题思路:

简单的二分,为了避免纠结精度和临界点问题可以把x的范围开的大一些,题目给的是0~100,我开了-1~101,只要x不在0~100以内就说明无解。

AC代码:

#include <iostream>
#include <cstdio>
using namespace std;
bool flag(double x,double y)
{
    if(8 * x * x * x * x + 7 * x * x * x + 2 * x * x + 3 * x + 6 >= y)
        return true;
    else
        return false;
}
int main()
{
    int t;
    double y;
    scanf("%d", &t);
    while(t--)
    {
        scanf("%lf", &y);
        double low = -1, high = 101, mid;
        while(high - low > 1e-8)
        {
            mid = (high + low) / 2;
            if(flag(mid,y))
                high = mid;
            else
                low = mid;
        }
        if(low < 0 || low > 100)
            printf("No solution!\n");
        else
            printf("%.4lf\n",low);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: