您的位置:首页 > 其它

hdu 1086 You can Solve a Geometry Problem too(求线段相交点个数 模板)

2014-07-26 20:55 447 查看
题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1086

You can Solve a Geometry Problem too

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 7227 Accepted Submission(s): 3504

Problem Description
Many geometry(几何)problems were designed in the ACM/ICPC. And now, I also prepare a geometry problem for this final exam. According to the experience of many ACMers, geometry problems are always much trouble, but this problem is very
easy, after all we are now attending an exam, not a contest :)

Give you N (1<=N<=100) segments(线段), please output the number of all intersections(交点). You should count repeatedly if M (M>2) segments intersect at the same point.

Note:

You can assume that two segments would not intersect at more than one point.


Input
Input contains multiple test cases. Each test case contains a integer N (1=N<=100) in a line first, and then N lines follow. Each line describes one segment with four float values x1, y1, x2, y2 which are coordinates of the segment’s
ending.

A test case starting with 0 terminates the input and this test case is not to be processed.


Output
For each case, print the number of intersections, and one line one case.


Sample Input
2
0.00 0.00 1.00 1.00
0.00 1.00 1.00 0.00
3
0.00 0.00 1.00 1.00
0.00 1.00 1.00 0.000
0.00 0.00 1.00 0.00
0



Sample Output
1
3



Author
lcy

套用吉大模板;

代码如下:
#include <cstdio>
#include <iostream>
#include <algorithm>
using namespace std;
const double eps=1e-10;
struct point
{ 
	double x, y;
};
double min(double a, double b) 
{ 
	return a < b ? a : b;
}
double max(double a, double b) 
{ 
	return a > b ? a : b; 
}
bool inter(point a, point b, point c, point d)
{
	if (min(a.x, b.x) > max(c.x, d.x)||
		min(a.y, b.y) > max(c.y, d.y)||
		min(c.x, d.x) > max(a.x, b.x)||min(c.y, d.y) > max(a.y, b.y) ) return 0;
	double h, i, j, k;
	h = (b.x - a.x) * (c.y - a.y) - (b.y - a.y) * (c.x - a.x);
	i = (b.x - a.x) * (d.y - a.y) - (b.y - a.y) * (d.x - a.x);
	j = (d.x - c.x) * (a.y - c.y) - (d.y - c.y) * (a.x - c.x);
	k = (d.x - c.x) * (b.y - c.y) - (d.y - c.y) * (b.x - c.x);
	return h * i <= eps && j * k <= eps;
}
int main()
{
	int n;
	int i, j;
	point p[117][2];
	while(cin>>n && n)
	{
		for(i = 0; i < n; i++)
		{
			cin>>p[i][0].x>>p[i][0].y>>p[i][1].x>>p[i][1].y;
		}
		int count = 0;
		for(i = 0; i < n; i++)
		{
			for(j = i+1; j < n; j++)
			{
				if(inter(p[i][0],p[i][1],p[j][0],p[j][1]))
					count++;
			}
		}
		cout<<count<<endl;
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: 
相关文章推荐