您的位置:首页 > 其它

poj_1144/uva_315/zoj_1311 Network(割點模板題)

2014-07-26 00:31 477 查看
求割點的模板題,要求的critical places就是割點

下面是題目:

Network

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 9192 Accepted: 4319
Description
A Telephone Line Company (TLC) is establishing a new telephone cable network. They are connecting several places numbered by integers from 1 to N . No two places have the same number. The lines are bidirectional and always connect
together two places and in each place the lines end in a telephone exchange. There is one telephone exchange in each place. From each place it is

possible to reach through lines every other place, however it need not be a direct connection, it can go through several exchanges. From time to time the power supply fails at a place and then the exchange does not operate. The officials from TLC realized that
in such a case it can happen that besides the fact that the place with the failure is unreachable, this can also cause that some other places cannot connect to each other. In such a case we will say the place (where the failure

occured) is critical. Now the officials are trying to write a program for finding the number of all such critical places. Help them.
Input
The input file consists of several blocks of lines. Each block describes one network. In the first line of each block there is the number of places N < 100. Each of the next at most N lines contains the number of a place followed
by the numbers of some places to which there is a direct line from this place. These at most N lines completely describe the network, i.e., each direct connection of two places in the network is contained at least in one row. All numbers in one line are separated

by one space. Each block ends with a line containing just 0. The last block has only one line with N = 0;
Output
The output contains for each block except the last in the input file one line containing the number of critical places.
Sample Input
5
5 1 2 3 4
0
6
2 1 3
5 4 6 2
0
0

Sample Output
1
2

Hint
You need to determine the end of one line.In order to make it's easy to determine,there are no extra blank before the end of each line.
Source
Central Europe 1996
下面是AC的代碼:

#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<vector>
#include<algorithm>
using namespace std;
#define range 110
vector<int>adj[range];
int cut_vertex[range],dfn[range],low[range];
int jj,depth;
void dfs(int k,int pa)
{
int child,i,u,flag;
low[k]=dfn[k]=++depth;
child=0;
flag=0;
for(i=0;i<adj[k].size();i++)
{
int next=adj[k][i];

if(!dfn[next])
{
child++;
dfs(next,k);
low[k]=min(low[k],low[next]);
if(low[next]>=dfn[k])
flag=1;
}
else if(next!=pa)
{
low[k]=min(low[k],dfn[next]);
}
}
if((child>=2 || pa>-1) && flag)
cut_vertex[++jj]=k;
return;
}
int main()
{
freopen("in.txt","r",stdin);
int i,n;
while(1)
{
scanf("%d",&n);
if(!n) break;
for(i=0;i<=n;i++) adj[i].clear();
while(1)
{
int u;
char c;
scanf("%d%c",&u,&c);
if(!u) break;
while(1)
{
int v;
char cc;
scanf("%d%c",&v,&cc);
adj[u].push_back(v);
adj[v].push_back(u);
if(cc!=' ') break;
}
}
jj=0;
depth=0;
memset(dfn,0,sizeof(dfn));
dfs(1,-1);
printf("%d\n",jj);
}
return 0;
}


 

 
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  图论 割点 算法