您的位置:首页 > 其它

poj 1125 -- Stockbroker Grapevine

2014-07-08 15:53 330 查看
Stockbroker Grapevine

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 26191Accepted: 14459
Description

Stockbrokers are known to overreact to rumours. You have been contracted to develop a method of spreading disinformation amongst the stockbrokers to give your employer the tactical edge in the stock market. For maximum effect, you have to spread the rumours in the fastest possible way.

Unfortunately for you, stockbrokers only trust information coming
from their "Trusted sources" This means you have to take into account
the structure of their contacts when starting a rumour. It takes a
certain amount of time for a specific stockbroker to pass the rumour on
to each of his colleagues. Your task will be to write a program that
tells you which stockbroker to choose as your starting point for the
rumour, as well as the time it will take for the rumour to spread
throughout the stockbroker community. This duration is measured as the
time needed for the last person to receive the information.
Input

Your
program will input data for different sets of stockbrokers. Each set
starts with a line with the number of stockbrokers. Following this is a
line for each stockbroker which contains the number of people who they
have contact with, who these people are, and the time taken for them to
pass the message to each person. The format of each stockbroker line is
as follows: The line starts with the number of contacts (n), followed by
n pairs of integers, one pair for each contact. Each pair lists first a
number referring to the contact (e.g. a '1' means person number one in
the set), followed by the time in minutes taken to pass a message to
that person. There are no special punctuation symbols or spacing rules.

Each person is numbered 1 through to the number of stockbrokers. The
time taken to pass the message on will be between 1 and 10 minutes
(inclusive), and the number of contacts will range between 0 and one
less than the number of stockbrokers. The number of stockbrokers will
range from 1 to 100. The input is terminated by a set of stockbrokers
containing 0 (zero) people.

Output

For
each set of data, your program must output a single line containing the
person who results in the fastest message transmission, and how long
before the last person will receive any given message after you give it
to this person, measured in integer minutes.

It is possible that your program will receive a network of
connections that excludes some persons, i.e. some people may be
unreachable. If your program detects such a broken network, simply
output the message "disjoint". Note that the time taken to pass the
message from person A to person B is not necessarily the same as the
time taken to pass it from B to A, if such transmission is possible at
all.
Sample Input

3
2 2 4 3 5
2 1 2 3 6
2 1 2 2 2
5
3 4 4 2 8 5 3
1 5 8
4 1 6 4 10 2 7 5 2
0
2 2 5 1 5
0

Sample Output

3 2
3 10

水题。意思是通过股票经纪人散播谣言,给出经纪人散播谣言的时间,求从哪个经纪人开始花费时间最少,是多少。。
dijkstra 即可。


/*======================================================================
*           Author :   kevin
*         Filename :   StockbrokerGrapevine.cpp
*       Creat time :   2014-07-08 15:19
*      Description :
========================================================================*/
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstring>
#include <queue>
#include <cmath>
#define clr(a,b) memset(a,b,sizeof(a))
#define M 105
#define INF 0x7f7f7f7f
using namespace std;
int c[M][M],dis[M],n;
bool vis[M];
int dijkstra(int vo)
{
int i,j,k;
for(i = 0; i < n; i++){
dis[i] = c[vo][i];
vis[i] = false;
}
vis[vo] = true;
j = 0;
for(i = 1; i < n; i++){
int _min = INF;
for(k = 0; k < n; k++){
if(_min > dis[k] && !vis[k]){
_min = dis[k];
j = k;
}
}
vis[j] = true;
for(k = 0; k < n; k++){
if(!vis[k] && dis[k] > dis[j] + c[j][k]){
dis[k] = dis[j] + c[j][k];
}
}
}
int _max = 0;
for(int i = 0; i < n; i++){
if(_max < dis[i] && i != vo){
_max = dis[i];
}
}
return _max;
}
int main(int argc,char *argv[])
{
while(scanf("%d",&n)!=EOF && n){
for(int i = 0; i <= n; i++){
for(int j = i; j <= n; j++){
c[i][j] = c[j][i] = INF;
}
}
int t,a,v;
for(int i = 0; i < n; i++){
scanf("%d",&t);
for(int j = 0; j < t; j++){
scanf("%d%d",&a,&v);
c[i][a-1] = v;
}
}
int ans = INF,cnt;
for(int i = 0; i < n; i++){
int t = dijkstra(i);
if(ans > t){
ans = t;
cnt = i;
}
}
if(ans == INF){
printf("disjoint\n");
}
else
printf("%d %d\n",cnt+1,ans);
}
return 0;
}


View Code
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: