您的位置:首页 > 运维架构

LOOPS - HDU 3853 期望dp

2014-07-05 21:12 357 查看


LOOPS

Time Limit: 15000/5000 MS (Java/Others) Memory Limit: 125536/65536 K (Java/Others)

Total Submission(s): 1915 Accepted Submission(s): 757



Problem Description

Akemi Homura is a Mahou Shoujo (Puella Magi/Magical Girl).

Homura wants to help her friend Madoka save the world. But because of the plot of the Boss Incubator, she is trapped in a labyrinth called LOOPS.



The planform of the LOOPS is a rectangle of R*C grids. There is a portal in each grid except the exit grid. It costs Homura 2 magic power to use a portal once. The portal in a grid G(r, c) will send Homura to the grid below G (grid(r+1, c)), the grid on the
right of G (grid(r, c+1)), or even G itself at respective probability (How evil the Boss Incubator is)!

At the beginning Homura is in the top left corner of the LOOPS ((1, 1)), and the exit of the labyrinth is in the bottom right corner ((R, C)). Given the probability of transmissions of each portal, your task is help poor Homura calculate the EXPECT magic power
she need to escape from the LOOPS.



Input

The first line contains two integers R and C (2 <= R, C <= 1000).

The following R lines, each contains C*3 real numbers, at 2 decimal places. Every three numbers make a group. The first, second and third number of the cth group of line r represent the probability of transportation to grid (r, c), grid (r, c+1), grid (r+1,
c) of the portal in grid (r, c) respectively. Two groups of numbers are separated by 4 spaces.

It is ensured that the sum of three numbers in each group is 1, and the second numbers of the rightmost groups are 0 (as there are no grids on the right of them) while the third numbers of the downmost groups are 0 (as there are no grids below them).

You may ignore the last three numbers of the input data. They are printed just for looking neat.

The answer is ensured no greater than 1000000.

Terminal at EOF



Output

A real number at 3 decimal places (round to), representing the expect magic power Homura need to escape from the LOOPS.



Sample Input

2 2
0.00 0.50 0.50    0.50 0.00 0.50
0.50 0.50 0.00    1.00 0.00 0.00




Sample Output

6.000


题意:在C*R的方格中,每次可能呆在原地,往下走或往右走。每次的消耗是2,问你从左上到右下的消耗期望是多少。

思路:常规的期望dp,另外注意呆在原地为1的情况。

AC代码如下:

#include<cstdio>
#include<cstring>
using namespace std;
double num[1010][1010][3],dp[1010][1010];
int main()
{ int n,m,i,j,k;
  while(~scanf("%d%d",&n,&m))
  {memset(dp,0,sizeof(dp));
   for(i=1;i<=n;i++)
   for(j=1;j<=m;j++)
    for(k=0;k<=2;k++)
     scanf("%lf",&num[i][j][k]);
  for(i=n;i>=1;i--)
   for(j=m;j>=1;j--)
   { if(num[i][j][0]==1)
      dp[i][j]=0;
     else
     dp[i][j]=(dp[i][j+1]*num[i][j][1]+dp[i+1][j]*num[i][j][2]+2)/(1-num[i][j][0]);
   }
  printf("%.3f\n",dp[1][1]);
  }
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: