您的位置:首页 > 其它

POJ 1321 - 棋盘问题

2014-06-26 09:57 295 查看

棋盘问题

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 21574Accepted: 10712
Description
在一个给定形状的棋盘(形状可能是不规则的)上面摆放棋子,棋子没有区别。要求摆放时任意的两个棋子不能放在棋盘中的同一行或者同一列,请编程求解对于给定形状和大小的棋盘,摆放k个棋子的所有可行的摆放方案C。
Input
输入含有多组测试数据。

每组数据的第一行是两个正整数,n k,用一个空格隔开,表示了将在一个n*n的矩阵内描述棋盘,以及摆放棋子的数目。 n <= 8 , k <= n

当为-1 -1时表示输入结束。

随后的n行描述了棋盘的形状:每行有n个字符,其中 # 表示棋盘区域, . 表示空白区域(数据保证不出现多余的空白行或者空白列)。

Output
对于每一组数据,给出一行输出,输出摆放的方案数目C (数据保证C<2^31)。
Sample Input
2 1
#.
.#
4 4
...#
..#.
.#..
#...
-1 -1

Sample Output
2
1


感觉和八皇后差不多,直接DFS,记得标记哪些行用过。

#include <stdio.h>
#include <iostream>
#include <vector>
#include <algorithm>
#include <cstring>
#include <string>
#include <map>
#include <cmath>
#include <queue>
#include <set>

using namespace std;

//#define WIN
#ifdef WIN
typedef __int64 LL;
#define iform "%I64d"
#define oform "%I64d\n"
#define oform1 "%I64d"
#else
typedef long long LL;
#define iform "%lld"
#define oform "%lld\n"
#define oform1 "%lld"
#endif

#define S64I(a) scanf(iform, &(a))
#define P64I(a) printf(oform, (a))
#define S64I1(a) scanf(iform1, &(a))
#define P64I1(a) printf(oform1, (a))
#define FOR(i, s, t) for(int (i)=(s); (i)<(t); (i)++)

const int INF = 0x3f3f3f3f;
const double eps = 10e-9;
const double PI = (4.0*atan(1.0));

const int maxn = 20;
int n, k;
int ans;
char G[maxn][maxn];
int vis[maxn];

void dfs(int cur, int has) {
if(cur > n) return ;
if(has == k) {
ans++;
return ;
}
for(int i=0; i<n; i++) if(G[cur][i] == '#' && !vis[i]) {
vis[i] = 1;
dfs(cur+1, has+1);
vis[i] = 0;
}
dfs(cur+1, has);
}

int main() {

while(scanf("%d%d", &n, &k) != EOF && !(n==-1 && k==-1)) {
for(int i=0; i<n; i++) {
for(int j=0; j<n; j++) {
char c = getchar();
while(c != '#' && c != '.') c = getchar();
G[i][j] = c;
}
}
ans = 0;
memset(vis, 0, sizeof(vis));
dfs(0, 0);
printf("%d\n", ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: