您的位置:首页 > 其它

POJ-2155-Matrix(二维树状数组 & 二维线段树)

2014-05-26 07:36 561 查看
Description

Given an N*N matrix A, whose elements are either 0 or 1. A[i, j] means the number in the i-th row and j-th column. Initially we have A[i, j] = 0 (1 <= i, j <= N). 

We can change the matrix in the following way. Given a rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2), we change all the elements in the rectangle by using "not" operation (if it is a '0' then change it into '1' otherwise change
it into '0'). To maintain the information of the matrix, you are asked to write a program to receive and execute two kinds of instructions. 

1. C x1 y1 x2 y2 (1 <= x1 <= x2 <= n, 1 <= y1 <= y2 <= n) changes the matrix by using the rectangle whose upper-left corner is (x1, y1) and lower-right corner is (x2, y2). 

2. Q x y (1 <= x, y <= n) querys A[x, y]. 

Input

The first line of the input is an integer X (X <= 10) representing the number of test cases. The following X blocks each represents a test case. 

The first line of each block contains two numbers N and T (2 <= N <= 1000, 1 <= T <= 50000) representing the size of the matrix and the number of the instructions. The following T lines each represents an instruction having the format "Q x y" or "C x1 y1 x2
y2", which has been described above. 

Output

For each querying output one line, which has an integer representing A[x, y]. 

There is a blank line between every two continuous test cases. 

Sample Input
1
2 10
C 2 1 2 2
Q 2 2
C 2 1 2 1
Q 1 1
C 1 1 2 1
C 1 2 1 2
C 1 1 2 2
Q 1 1
C 1 1 2 1
Q 2 1

Sample Output
1
0
0
1


二维树状数组解法:用二维树状数组来维护顶点出现的次数,每加入一个矩形,就把四个顶点加进去(注意边界问题,x2,y2要加一)。查询的时候就算出(1,1)到(x,y)的顶点的总数,奇数就为1,偶数就是0。

#include <stdio.h>

int sum[1005][1005],n,m;

int lowbit(int x)
{
return x&-x;
}

void update(int x,int y)
{
for(int i=x;i<=n;i+=lowbit(i))
{
for(int j=y;j<=n;j+=lowbit(j))
{
sum[i][j]++;
}
}
}

int query(int x,int y)
{
int t=0;

for(int i=x;i>0;i-=lowbit(i))
{
for(int j=y;j>0;j-=lowbit(j))
{
t+=sum[i][j];
}
}

return t&1;
}

int main()
{
int T,i,j,x1,y1,x2,y2;
char s[5];

scanf("%d",&T);

while(T--)
{
scanf("%d%d",&n,&m);

for(i=1;i<=n;i++) for(j=1;j<=n;j++) sum[i][j]=0;

while(m--)
{
scanf("%s",s);

if(s[0]=='C')
{
scanf("%d%d%d%d",&x1,&y1,&x2,&y2);

update(x1,y1);
update(x1,y2+1);
update(x2+1,y2+1);
update(x2+1,y1);
}
else
{
scanf("%d%d",&x1,&y1);
printf("%d\n",query(x1,y1));
}
}

printf("\n");
}
}


二维线段树解法:

#include <stdio.h>

int n,m;
bool node[4000][4000],ans;

void buildy(int x,int idx,int s,int e)
{
if(s!=e)
{
int mid=(s+e)>>1;

buildy(x,idx<<1,s,mid);
buildy(x,idx<<1|1,mid+1,e);
}

node[x][idx]=0;
}

void build(int idx,int s,int e)
{
buildy(idx,1,1,n);

if(s!=e)
{
int mid=(s+e)>>1;

build(idx<<1,s,mid);
build(idx<<1|1,mid+1,e);
}

}

void updatey(int x,int idx,int s,int e,int l,int r)
{
if(s==l && e==r)
{
node[x][idx]=!node[x][idx];

return;
}

int mid=(s+e)>>1;

if(r<=mid) updatey(x,idx<<1,s,mid,l,r);
else if(l>mid) updatey(x,idx<<1|1,mid+1,e,l,r);
else
{
updatey(x,idx<<1,s,mid,l,mid);
updatey(x,idx<<1|1,mid+1,e,mid+1,r);
}
}

void update(int idx,int s,int e,int l,int r,int ly,int ry)
{
if(s==l && e==r)
{
updatey(idx,1,1,n,ly,ry);

return;
}

int mid=(s+e)>>1;

if(r<=mid) update(idx<<1,s,mid,l,r,ly,ry);
else if(l>mid) update(idx<<1|1,mid+1,e,l,r,ly,ry);
else
{
update(idx<<1,s,mid,l,mid,ly,ry);
update(idx<<1|1,mid+1,e,mid+1,r,ly,ry);
}
}

void queryy(int x,int idx,int s,int e,int pos)
{
ans^=node[x][idx];

if(s!=e)
{
int mid=(s+e)>>1;

if(pos<=mid) queryy(x,idx<<1,s,mid,pos);
else queryy(x,idx<<1|1,mid+1,e,pos);
}
}

void query(int idx,int s,int e,int pos,int y)
{
queryy(idx,1,1,n,y);

if(s!=e)
{
int mid=(s+e)>>1;

if(pos<=mid) query(idx<<1,s,mid,pos,y);
else query(idx<<1|1,mid+1,e,pos,y);
}
}

int main()
{
int T,a,b,c,d;
char s[5];

scanf("%d",&T);

while(T--)
{
scanf("%d%d",&n,&m);

build(1,1,n);

while(m--)
{
scanf("%s",s);

if(s[0]=='C')
{
scanf("%d%d%d%d",&a,&c,&b,&d);

update(1,1,n,a,b,c,d);
}
else
{
scanf("%d%d",&a,&b);

ans=0;

query(1,1,n,a,b);

printf("%d\n",ans);
}
}

printf("\n");
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: