您的位置:首页 > 其它

POJ 1552-Doubles

2014-05-22 18:21 239 查看
Description
As part of an arithmetic competency program, your students will be given randomly generated lists of from 2 to 15 unique positive integers and asked to determine how many items in each list are twice some other item in the same
list. You will need a program to help you with the grading. This program should be able to scan the lists and output the correct answer for each one. For example, given the list

1 4 3 2 9 7 18 22


your program should answer 3, as 2 is twice 1, 4 is twice 2, and 18 is twice 9.

Input
The input will consist of one or more lists of numbers. There will be one list of numbers per line. Each list will contain from 2 to 15 unique positive integers. No integer will be larger than 99. Each line will be terminated with
the integer 0, which is not considered part of the list. A line with the single number -1 will mark the end of the file. The example input below shows 3 separate lists. Some lists may not contain any doubles.
Output
The output will consist of one line per input list, containing a count of the items that are double some other item.

Sample Input
1 4 3 2 9 7 18 22 0
2 4 8 10 0
7 5 11 13 1 3 0
-1

Sample Output
3
2
0

Source
Mid-Central USA 2003

题目大意:一串数,以0结尾,找出一个数是另一个数的两倍的有几组数。
思路:水。
代码:
import java.util.*;
public class Main {
public static void main(String[] args) {

Scanner scan = new Scanner(System.in);

boolean flag = true;

int a[] = new int[16];

while (scan.hasNext() && flag) {

int k = 0;

int ans = 0;

a = new int[16];

while (true) {

int b = scan.nextInt();

if (b == 0)

break;

if (b == -1) {

flag = false;

break;

}

a[k] = b;

k++;

}

if(flag){

for (int i = 0; i <k; i++) {

for (int j = 0; j <k; j++) {

if (a[j] == a[i] * 2) {

ans += 1;

}

}

}

System.out.println(ans);}

}
}
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: