您的位置:首页 > 其它

[sg简单应用] poj 1082 Calendar Game

2014-05-15 16:49 477 查看
题目链接:

http://poj.org/problem?id=1082

Calendar Game

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 4742Accepted: 2236
Description

Adam and Eve enter this year's ACM International Collegiate Programming Contest. Last night, they played the Calendar Game, in celebration of this contest. This game consists of the dates from January 1, 1900 to November 4, 2001, the contest day. The game starts
by randomly choosing a date from this interval. Then, the players, Adam and Eve, make moves in their turn with Adam moving first: Adam, Eve, Adam, Eve, etc. There is only one rule for moves and it is simple: from a current date, a player in his/her turn can
move either to the next calendar date or the same day of the next month. When the next month does not have the same day, the player moves only to the next calendar date. For example, from December 19, 1924, you can move either to December 20, 1924, the next
calendar date, or January 19, 1925, the same day of the next month. From January 31 2001, however, you can move only to February 1, 2001, because February 31, 2001 is invalid.

A player wins the game when he/she exactly reaches the date of November 4, 2001. If a player moves to a date after November 4, 2001, he/she looses the game.

Write a program that decides whether, given an initial date, Adam, the first mover, has a winning strategy.

For this game, you need to identify leap years, where February has 29 days. In the Gregorian calendar, leap years occur in years exactly divisible by four. So, 1993, 1994, and 1995 are not leap years, while 1992 and 1996 are leap years. Additionally, the years
ending with 00 are leap years only if they are divisible by 400. So, 1700, 1800, 1900, 2100, and 2200 are not leap years, while 1600, 2000, and 2400 are leap years.
Input

The input consists of T test cases. The number of test cases (T ) is given in the first line of the input file. Each test case is written in a line and corresponds to an initial date. The three integers in a line, YYYY MM DD, represent the date of the DD-th
day of MM-th month in the year of YYYY. Remember that initial dates are randomly chosen from the interval between January 1, 1900 and November 4, 2001.
Output

Print exactly one line for each test case. The line should contain the answer "YES" or "NO" to the question of whether Adam has a winning strategy against Eve. Since we have T test cases, your program should output totally T lines of "YES" or "NO".
Sample Input
3 
2001 11 3 
2001 11 2 
2001 10 3

Sample Output
YES
NO
NO

Source

Taejon 2001
[Submit] [Go Back] [Status]
[Discuss]

题目意思:

两个人轮流的报日期,只能报下一天或下一个月的这天,日期的范围是1900.1.1--2001.11.4,最后不能报的输,两人都足够聪明,求先报者能否会赢。

解题思路:

sg函数的简单应用,求出必胜必败点即可,从后往前推。

代码:

//#include<CSpreadSheet.h>

#include<iostream>
#include<cmath>
#include<cstdio>
#include<sstream>
#include<cstdlib>
#include<string>
#include<string.h>
#include<cstring>
#include<algorithm>
#include<vector>
#include<map>
#include<set>
#include<stack>
#include<list>
#include<queue>
#include<ctime>
#include<bitset>
#include<cmath>
#define eps 1e-6
#define INF 0x3f3f3f3f
#define PI acos(-1.0)
#define ll __int64
#define LL long long
#define lson l,m,(rt<<1)
#define rson m+1,r,(rt<<1)|1
#define M 1000000007
//#pragma comment(linker, "/STACK:1024000000,1024000000")
using namespace std;

int days[2][13]={0,31,28,31,30,31,30,31,31,30,31,30,31,
0,31,29,31,30,31,30,31,31,30,31,30,31};
int sg[2200][15][33];

bool isleap(int y) //判断是否是润年
{
    if((!(y%4)&&(y%100))||!(y%400))
        return true;
    return false;
}

void init()
{
    memset(sg,-1,sizeof(sg));
    sg[2001][11][4]=0;sg[2001][11][3]=1,sg[2001][11][2]=0;sg[2001][11][1]=1;

    int le=isleap(2001);
    for(int i=10;i>=1;i--)
    {
        int dd=days[le][i]; //每个月的最后一天单独处理,它的下一天是下个月的最后一天
        if(!sg[2001][i+1][1]||!sg[2001][i+1][dd]) //只要有一个是必败点,该点一定是必胜点
            sg[2001][i][dd]=1;
        else
            sg[2001][i][dd]=0;
        for(int j=dd-1;j>=1;j--)
        {
            if(!sg[2001][i+1][j]||!sg[2001][i][j+1])
                sg[2001][i][j]=1;
            else
                sg[2001][i][j]=0;
        }
    }
    for(int y=2000;y>=1900;y--)
    {
        le=isleap(y);
        for(int m=12;m>=1;m--)
        {
            int dd=days[le][m]; 

            if(m==12) //最后一个月的最后一天单独拿出来
            {
                if(!sg[y+1][1][1]||!sg[y+1][1][dd])
                    sg[y][m][dd]=1;
                else
                    sg[y][m][dd]=0;
            }
            else
            {
                if(!sg[y][m+1][1]||!sg[y][m+1][dd])
                    sg[y][m][dd]=1;
                else
                    sg[y][m][dd]=0;
            }
            for(int d=dd-1;d>=1;d--)
            {
                if(!sg[y][m+1][d]||!sg[y][m][d+1])
                    sg[y][m][d]=1;
                else
                    sg[y][m][d]=0;
            }
        }
    }
}
int main()
{
   //freopen("in.txt","r",stdin);
   //freopen("out.txt","w",stdout);
   init();

   int t;

   scanf("%d",&t);
   while(t--)
   {
       int yy,mm,dd;

       scanf("%d%d%d",&yy,&mm,&dd);
       if(sg[yy][mm][dd])
            printf("YES\n");
       else
            printf("NO\n");
   }
   return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: