您的位置:首页 > 其它

poj 3278 队列+bfs

2014-04-29 21:45 120 查看
http://poj.org/problem?id=3278

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number
line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute

* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K
Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
Sample Input
5 17

Sample Output
4

Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.
用到了stl里面的队列,和bfs 
#include <stdio.h>
#include <string.h>
#include <iostream>
#include <queue>
using namespace std;
const int maxn=100005;
int visit[100005],num[100005];
queue<int> q;
int bfs(int n,int m)
{
int next;
int head;
q.push(n);
visit
=1;
while(!q.empty())
{
head=q.front();
q.pop();
for(int i=0; i<3; i++)
{
if(i==0)
{
next=head-1;
}
else if(i==1)
{
next=head+1;
}
else next=2*head;
if(next<0||next>=maxn)
continue;
if(!visit[next])//已经访问过了,说明在这次到达已到达过一次,这次绝对不是最短的了
{
visit[next]=1;
q.push(next);
num[next]=num[head]+1;
}
if(next==m)
return num[next];
}
}
}
int main()
{
int n,m;
while(~scanf("%d%d",&n,&m))
{
memset(visit,0,sizeof(visit));
memset(num,0,sizeof(num));
while(!q.empty())
q.pop();
if(n>=m)
printf("%d\n",n-m);
else
printf("%d\n",bfs(n,m));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: