您的位置:首页 > 其它

杭电oj 1069 Monkey and Banana 最长递增子序列

2014-04-29 12:01 423 查看
Monkey and Banana

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6866 Accepted Submission(s):
3516


[align=left]Problem Description[/align]
A group of researchers are designing an experiment to
test the IQ of a monkey. They will hang a banana at the roof of a building, and
at the mean time, provide the monkey with some blocks. If the monkey is clever
enough, it shall be able to reach the banana by placing one block on the top
another to build a tower and climb up to get its favorite food.


The
researchers have n types of blocks, and an unlimited supply of blocks of each
type. Each type-i block was a rectangular solid with linear dimensions (xi, yi,
zi). A block could be reoriented so that any two of its three dimensions
determined the dimensions of the base and the other dimension was the height.


They want to make sure that the tallest tower possible by stacking
blocks can reach the roof. The problem is that, in building a tower, one block
could only be placed on top of another block as long as the two base dimensions
of the upper block were both strictly smaller than the corresponding base
dimensions of the lower block because there has to be some space for the monkey
to step on. This meant, for example, that blocks oriented to have equal-sized
bases couldn't be stacked.


Your job is to write a program that
determines the height of the tallest tower the monkey can build with a given set
of blocks.


[align=left]Input[/align]
The input file will contain one or more test cases. The
first line of each test case contains an integer n,

representing the number
of different blocks in the following data set. The maximum value for n is
30.

Each of the next n lines contains three integers representing the values
xi, yi and zi.

Input is terminated by a value of zero (0) for n.

[align=left]Output[/align]
For each test case, print one line containing the case
number (they are numbered sequentially starting from 1) and the height of the
tallest possible tower in the format "Case case: maximum height =
height".


[align=left]Sample Input[/align]

1

10 20 30

2

6 8 10

5 5 5

7

1 1 1

2 2 2

3 3 3

4 4 4

5 5 5

6 6 6

7 7 7

5

31 41 59

26 53 58
97 93 23
84 62 64

33 83 27
0

[align=left]Sample Output[/align]
[align=left] [/align]

Case 1: maximum height = 40
Case 2: maximum height = 21
Case 3: maximum height = 28
Case 4: maximum height = 342

这道题变相的让求最长递增(减)子序列的和。题目的大意是给你n组数,每组有三个整数,分别代表长方体的长、宽、高,但又不确定三者之间的具体关系,所以给定的三个整数又可以分成三组数据,例如给定10、20、30,则有(30,20,10)、(30,10,20)、(20,10,30)三种情况。将所有的数据以长和宽为依据从小到大(或从大到小)排列之后,求得最长递增(减)子序列,然后将序列的高相加,即得到最大的高度。
状态转移方程为dp[i] = max(dp[i],dp[j]+r[i].z),0<=j<i。

下面是代码:

#include <iostream>
#include <algorithm>
using namespace std;

typedef struct rectangular{
int x,y,z;
}R;
R r[105];
int k;
bool cmp(R a,R b)
{
if(a.x == b.x)
return a.y<b.y;
return a.x<b.x;
}
int dp()
{
int i, j;
int dp[105];
sort(r,r+k,cmp);
int maxheight = 0;
for(i=0; i<k; i++)
{
dp[i] = r[i].z;
for(j=0;j<i; j++)
if(r[i].x>r[j].x && r[i].y>r[j].y)
if(dp[j]+r[i].z > dp[i])
dp[i] = dp[j]+r[i].z;
if(maxheight < dp[i])
maxheight = dp[i];
}
return maxheight;
}
int main()
{
int n, i, cas=1;
int x, y, z;
while(cin>>n && n)
{
k = 0;
for(i=0; i<n; i++)
{
cin>>x>>y>>z;
r[k].x = max(x,y);
r[k].y = min(x,y);
r[k++].z = z;
r[k].x = max(x,z);
r[k].y = min(x,z);
r[k++].z = y;
r[k].x = max(y,z);
r[k].y = min(y,z);
r[k++].z = x;
}
cout<<"Case "<<cas++<<": maximum height = "<<dp()<<endl;
}
return 0;
}


View Code
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: