您的位置:首页 > 其它

[ACM_动态规划] hdu1003 Max Sum [最大连续子串和]

2014-04-18 21:23 363 查看
[align=left]Problem Description[/align]
Given a sequence a[1],a[2],a[3]......a
, your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

[align=left]Input[/align]
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

[align=left]Output[/align]
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

[align=left]Sample Input[/align]

2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5

[align=left]Sample Output[/align]

Case 1: 14 1 4 Case 2: 7 1 6

???->>>>设某序列[x,j]的和大于等于0,则后面再来一个数肯定要接在上面;如果其小于0则后面来的数不要接在其后面,要把这个序列的开头设为当前输入的位置。

#include <iostream>
using namespace std;

int main(){
int t,n,temp,pos1,pos2,max,now,x,i,j;
cin>>t;
for (i=1;i<=t;i++){
cin>>n>>temp;//输入n和第一个数
now=max=temp;//令now和max都等于第一个数
pos1=pos2=x=1;//令初始位置为1
for(j=2;j<=n;j++){//循环输入2-n个
cin>>temp;
if (now+temp<temp)//如果now为负就从新的位置开始
now=temp,x=j;//x保存当前开头位置
else//否则就在now后加上输入数据
now+=temp;
if(now>max)//如果now>max就更新max
max=now,pos1=x,pos2=j;
}
cout<<"Case "<<i<<":"<<endl<<max<<" "<<pos1<<" "<<pos2<<endl;
if (i!=t)cout<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: