您的位置:首页 > 其它

[2010山东ACM省赛] Greatest Number(数的组合+二分搜索)

2014-04-13 16:01 267 查看


Greatest Number



Time Limit: 1000ms Memory limit: 65536K 有疑问?点这里^_^


题目描述

Saya
likes math, because she think math can make her cleverer.

One
day, Kudo invited a very simple game:

Given N integers,
then the players choose no more than four integers from them (can be repeated) and add them together. Finally, the one whose sum is the largest wins the game. It seems very simple, but there is one more condition: the sum shouldn’t larger than a number M.

Saya
is very interest in this game. She says that since the number of integers is finite, we can enumerate all the selecting and find the largest sum. Saya calls the largest sum Greatest Number (GN). After reflecting for a while, Saya declares that she found the
GN and shows her answer.

Kudo
wants to know whether Saya’s answer is the best, so she comes to you for help.

Can
you help her to compute the GN?

输入

The
input consists of several test cases.

The first line of input in each test case contains two integers N (0<N≤1000)
and M(0 1000000000), which represent the number of integers and the upper bound.

Each of the next N lines
contains the integers. (Not larger than 1000000000)

The last case is followed by a line containing two zeros.

输出

For
each case, print the case number (1, 2 …) and the GN.

Your
output format should imitate the sample output. Print a blank line after each test case.

示例输入

2 10
100
2

0 0


示例输出

Case 1: 8


提示

来源

2010年山东省第一届ACM大学生程序设计竞赛

解题思路:

这题猛一看以为是多重背包问题,最多选四个数(可重复)要求小于m的这个四个数的和,m最大为十亿,开不出来这么大的数组。后来看了解题报告才发现这题不是背包问题,总体思路为把 符合要求的数存入temp[]数组中,两重循环求出所有数(包括相同)的2组合保存在一个数组sum中,排序,用二分查找任意取两个组合相加,求最大值就好了。需要注意的是,题目中说1组合,2组合,3组合也可以,那么就需要构造这个组合,只要把temp[]的第一个数设为0就可以了,这样所有数的2组合里面也包括了1组合,然后任意取两个组合数,就构成了1组合,2组合,3组合,4组合的所有情况。

代码:

#include <iostream>
#include <algorithm>
#include <string.h>
using namespace std;
int num;//输入的数
int temp[1002];//存合法输入的数
int sum[1000002];//存任意两个数之间的和

int main()
{
int n,m;
int cas=1;
while(cin>>n>>m&&(n||m))
{
temp[0]=0;//合法的第一个数设为0
int c=1,k=0;
for(int i=1;i<=n;i++)
{
cin>>num;
if(num<=m)
temp[c++]=num;
}
for(int i=0;i<c;i++)//temp[0]=0在此发挥作用,保证有1,2,3,4种组合,因为sum[]中存的类型有 两个相同数的和,两个不相同数的和
for(int j=i;j<c;j++)
{
if(temp[i]+temp[j]<=m)
sum[k++]=temp[i]+temp[j];
}//保证了1~4个数之间的任意组合
sort(sum,sum+k);//排序,为二分查找做准备
int max=0;
for(int i=0;i<k;i++)
{
int low=i,high=k-1;//注意low=i
while(low<=high)
{
int mid=(low+high)/2;
if(sum[i]+sum[mid]>m)
high=mid-1;
else
{
int t=sum[i]+sum[mid];
if(max<t)
max=t;
low=mid+1;
}
}
}
cout<<"Case "<<cas++<<": "<<max<<endl;
cout<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: