您的位置:首页 > 其它

POJ 1195 Mobile phones (二维树状数组)

2014-04-09 14:34 369 查看
链接:http://poj.org/problem?id=1195

Description
Suppose that the fourth generation mobile phone base stations in the Tampere area operate as follows. The area is divided into squares. The squares form an S * S matrix with the
rows and columns numbered from 0 to S-1. Each square contains a base station. The number of active mobile phones inside a square can change because a phone is moved from a square to another or a phone is switched on or off. At times, each base station reports
the change in the number of active phones to the main base station along with the row and the column of the matrix. 

Write a program, which receives these reports and answers queries about the current total number of active mobile phones in any rectangle-shaped area. 

Input
The input is read from standard input as integers and the answers to the queries are written to standard output as integers. The input is encoded as follows. Each input comes on
a separate line, and consists of one instruction integer and a number of parameter integers according to the following table. 



The values will always be in range, so there is no need to check them. In particular, if A is negative, it can be assumed that it will not reduce the square value below zero. The indexing starts at 0, e.g. for a table of size 4 * 4, we have 0 <= X <= 3 and
0 <= Y <= 3. 

Table size: 1 * 1 <= S * S <= 1024 * 1024 

Cell value V at any time: 0 <= V <= 32767 

Update amount: -32768 <= A <= 32767 

No of instructions in input: 3 <= U <= 60002 

Maximum number of phones in the whole table: M= 2^30 

Output
Your program should not answer anything to lines with an instruction other than 2. If the instruction is 2, then your program is expected to answer the query by writing the answer
as a single line containing a single integer to standard output.
Sample Input
0 4
1 1 2 3
2 0 0 2 2
1 1 1 2
1 1 2 -1
2 1 1 2 3
3

Sample Output
3
4


解题思路:

首先对二维数组进行初始化,然后更新,最后求和,对于求和,题目给出左上角和右下角的坐标x1, y1, x2, y2;求和时先求出以每个角的坐标为右上角求出左下部分到点(1, 1)的总和,这样求和就变成了sum(x2, y2) - sum(x1-1, y2)- sum(x2, y1-1) + sum(x1-1, y1-1);

代码如下:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#define MAXN 1050
#define RST(N)memset(N, 0, sizeof(N))
using namespace std;

double a[MAXN][MAXN], M;
int flag, S;

int lowbit(int x) { return x & (-x); }

void update(int x, int y, double d) //二维树状数组的更新;
{
while(x <= S) {
int My = y;
while(My <= S) {
a[x][My] += d;
My += lowbit(My);
}
x += lowbit(x);
}
}

int getsum(int x, int y) //二维树状数组的求和;
{
int sum = 0;
while(x > 0) {
int My = y;
while(My > 0) {
sum += a[x][My];
My -= lowbit(My);
}
x -= lowbit(x);
}
return sum;
}

int main()
{
int x1, y1, x2, y2;
while(~scanf("%d", &flag)) {
if(flag == 3) break;
else if(flag == 0) {
scanf("%d", &S);
RST(a);
}else if(flag == 1) {
scanf("%d %d %lf", &x1, &y1, &M);
update(x1+1, y1+1, M);
}else if(flag == 2) {
scanf("%d %d %d %d", &x1, &y1, &x2, &y2);
x1++, y1++, x2++, y2++;
int res = getsum(x2, y2)-getsum(x1-1, y2)-getsum(x2, y1-1)+getsum(x1-1, y1-1);
printf("%d\n", res);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  二维树状数组