您的位置:首页 > 产品设计 > UI/UE

HDU 1242 Rescue (搜索 DFS)

2014-04-07 14:14 423 查看


Rescue

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 14138 Accepted Submission(s): 5135



Problem Description

Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up,
down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)



Input

First line contains two integers stand for N and M.

Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend.

Process to the end of the file.



Output

For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life."



Sample Input

7 8
#.#####.
#.a#..r.
#..#x...
..#..#.#
#...##..
.#......
........




Sample Output

13




题意:天使被困在监狱,他的朋友们想见他,监狱的地形复杂,包括路(用点标示),墙(用#标示),天使的位置(用a标示),他的朋友(用r标示),监狱里还有守卫(用x标示),他的朋友只能向左右上下四个方向走,走以不花一单位时间,若碰上守卫,消灭守卫需要额外花费一单位时间。问最少多长时间天使能见到他的朋友。

本题需要注意的是,天使的朋友可能不只一个,所以,应该从天使的位置开始搜去找其朋友就ok了。

#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <climits>

const int MAX = 202;

char map[MAX][MAX];
int visit[MAX][MAX];
int n,m,ax,ay,minx;

void dfs(int x,int y,int len){
	if(x<0 || y<0 || x>=n || y>=m)return;
	if(len>=minx)return;
	if(map[x][y]=='#')return;
	if(visit[x][y]==1)return;
	if(map[x][y]=='r'){
		if(len<minx)minx=len;
		return;
	}
	if(map[x][y]=='x'){
		++len;
	}
	visit[x][y]=1;
	dfs(x+1,y,len+1);
	dfs(x-1,y,len+1);
	dfs(x,y+1,len+1);
	dfs(x,y-1,len+1);
	visit[x][y]=0;
}

int main(){

	//freopen("in.txt","r",stdin);
	int i,j,len;
	while(scanf("%d %d%*c",&n,&m)!=EOF){
		for(i=0;i<n;++i){
			for(j=0;j<m;++j){
				map[i][j]=getchar();
				if(map[i][j]=='a'){
					ax = i;
					ay = j;
				}
			}
			getchar();
		}
		len = 0;
		minx = INT_MAX;
		dfs(ax,ay,len);
		if(minx!=INT_MAX){
			printf("%d\n",minx);
		}else{
			printf("Poor ANGEL has to stay in the prison all his life.\n");
		}
		
	}
	
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: