您的位置:首页 > 其它

hdu1063 Exponentiation(大整数)

2014-04-03 22:36 253 查看

Exponentiation

Time Limit: 1000/500 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 6509    Accepted Submission(s): 1802


[align=left]Problem Description[/align]
Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems.

This problem requires that you write a program to compute the exact value of Rn where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25.

 

[align=left]Input[/align]
The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9.

 

[align=left]Output[/align]
The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don't print the decimal point if the result
is an integer.

 

[align=left]Sample Input[/align]

95.123 12
0.4321 20
5.1234 15
6.7592 9
98.999 10
1.0100 12

 

[align=left]Sample Output[/align]

548815620517731830194541.899025343415715973535967221869852721
.00000005148554641076956121994511276767154838481760200726351203835429763013462401
43992025569.928573701266488041146654993318703707511666295476720493953024
29448126.764121021618164430206909037173276672
90429072743629540498.107596019456651774561044010001
1.126825030131969720661201

import java.io.BufferedReader;
import java.io.InputStreamReader;
import java.io.FileReader;
import java.io.PrintWriter;
import java.io.OutputStreamWriter;
import java.util.StringTokenizer;
import java.io.IOException;
import java.math.BigDecimal;

class Main
{
public static final boolean DEBUG = false;
public StringTokenizer tokenizer;
public PrintWriter cout;
BufferedReader cin;

public void init() throws IOException
{
if (DEBUG) {
cin = new BufferedReader(new FileReader("d:\\OJ\\uva_in.txt"));
} else {
cin = new BufferedReader(new InputStreamReader(System.in));
}
tokenizer = new StringTokenizer("");

cout = new PrintWriter(new OutputStreamWriter(System.out));
}

public String next() throws IOException
{
while (!tokenizer.hasMoreTokens()) {
String s = cin.readLine();
if (s == null) return null;
tokenizer = new StringTokenizer(s);
}

return tokenizer.nextToken();
}

public void solve(BigDecimal bd, int n)
{
BigDecimal ans = bd.pow(n);

StringBuilder sb = new StringBuilder(ans.toPlainString());

if (sb.indexOf(".") != -1) {
for (int i = sb.length() - 1; i >= 1; i--) {
if (sb.charAt(i) == '0') {
sb.deleteCharAt(i);
} else break;
}
}

if (sb.charAt(sb.length() - 1) == '.') sb.deleteCharAt(sb.length() - 1);
if (sb.indexOf(".") != -1 && sb.charAt(0) == '0') sb.deleteCharAt(0);
cout.print(sb.toString());
cout.println();
cout.flush();
}

public static void main(String[] args) throws IOException
{
Main solver = new Main();
solver.init();
String s;

while ((s = solver.next()) != null) {
BigDecimal bd = new BigDecimal(s);
int n = Integer.valueOf(solver.next());

solver.solve(bd, n);
}

}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: