您的位置:首页 > 其它

逆序建表

2014-04-01 19:25 148 查看


题目描述

输入整数个数N,再输入N个整数,按照这些整数输入的相反顺序建立单链表,并依次遍历输出单链表的数据。


输入

第一行输入整数N;;

第二行依次输入N个整数,逆序建立单链表。


输出

依次输出单链表所存放的数据。


示例输入

10
11 3 5 27 9 12 43 16 84 22



示例输出

22 84 16 43 12 9 27 5 3 11


#include<stdio.h>

#include<stdlib.h>

struct node

{

    int data;

    struct node *next;

}*head,*q;

int main()

{

    int n;

    scanf("%d",&n);

    int i;

    head=(struct node*)malloc(sizeof(struct node));

    head->next=NULL;

    for(i=0;i<n;i++)

    {

        q=(struct node*)malloc(sizeof(struct node));

        q->next=NULL;

        scanf("%d",&q->data);

        q->next=head->next;

        head->next=q;

    }

    for(q=head->next;q!=NULL;q=q->next)

    {

        printf("%d ",q->data);

    }

    return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: