您的位置:首页 > 产品设计 > UI/UE

Children’s Queue

2014-03-26 17:21 323 查看


Children’s Queue

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 10040    Accepted Submission(s): 3198


Problem Description

There are many students in PHT School. One day, the headmaster whose name is PigHeader wanted all students stand in a line. He prescribed that girl can not be in single. In other words, either no girl in the queue or more than one girl stands side by side.
The case n=4 (n is the number of children) is like

FFFF, FFFM, MFFF, FFMM, MFFM, MMFF, MMMM

Here F stands for a girl and M stands for a boy. The total number of queue satisfied the headmaster’s needs is 7. Can you make a program to find the total number of queue with n children?

 

Input

There are multiple cases in this problem and ended by the EOF. In each case, there is only one integer n means the number of children (1<=n<=1000)

 

Output

For each test case, there is only one integer means the number of queue satisfied the headmaster’s needs.

 

Sample Input

1
2
3

 

Sample Output

1
2
4
#include<iostream>
#include<iomanip>
using namespace std;
int main()
{
int n;
int f[1001][101] = {0};
f[0][1]=1;
f[1][1]=1;
f[2][1]=2;
f[3][1]=4;
for(int i=4; i<1001; ++i)
{
for(int j=1;j<101;++j)
{
f[i][j]+=f[i-1][j]+f[i-2][j]+f[i-4][j];
f[i][j+1]+=f[i][j]/10000;
f[i][j]%=10000;
}
}

while(cin>>n)
{int j=100;
while(!f
[j])
{j--;}
cout<<f
[j];
j--;
for(;j>0;j--)
printf("%04d", f
[j]);
cout<<endl;

}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: