您的位置:首页 > 其它

poj 2406 kmp算法巩固之next数组的再理解

2014-03-25 20:21 323 查看
http://poj.org/problem?id=2406

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the
empty string) and a^(n+1) = a*(a^n).
Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.
Output

For each s you should print the largest n such that s = a^n for some string a.
Sample Input
abcd
aaaa
ababab
.

Sample Output
1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.
我学习的人家的,感觉还好,似乎很容易懂
#include <stdio.h>
#include <string.h>
#include <iostream>
const int N=1000005;
int next
,len;
char a
;
void get_next()
{
int i=0,j=-1;
next[0]=-1;
while(i<len)
{
if(j==-1||a[i]==a[j])
next[++i]=++j;
else
j=next[j];
}
}
int main()
{
while(~scanf("%s",a))
{
if(a[0]=='.')
break;
len=strlen(a);
get_next();
if(len%(len-next[len])!=0)
printf("1\n");
else
printf("%d\n",len/(len-next[len]));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: