您的位置:首页 > 其它

算法训练 寻找数组中最大值

2014-03-21 20:46 295 查看
问题描述

  对于给定整数数组a[],寻找其中最大值,并返回下标。

输入格式

  整数数组a[],数组元素个数小于1等于100。输出数据分作两行:第一行只有一个数,表示数组元素个数;第二行为数组的各个元素。

输出格式

  输出最大值,及其下标

样例输入

3

3 2 1

样例输出

3 0

///////////// from shhider
#include"stdio.h"
int main(){
int n, a[100];
int i, max, p = 0;
scanf("%d", &n);
scanf("%d", &a[0]);
max = a[0];
for( i=1; i<n; i++){
scanf("%d", &a[i]);
if( a[i]>max ){
max = a[i];
p = i;
}
}
printf("%d %d", max, p);
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: