您的位置:首页 > 其它

HDU 1019Least Common Multiple

2014-03-19 20:22 253 查看
Description

The least common multiple (LCM) of a set of positive integers is the smallest positive integer which is divisible by all the numbers in the set. For example, the LCM of 5, 7 and 15 is 105.

Input

Input will consist of multiple problem instances. The first line of the input will contain a single integer indicating the number of problem instances. Each instance will consist of a single line of the form m n1 n2 n3 ... nm where
m is the number of integers in the set and n1 ... nm are the integers. All integers will be positive and lie within the range of a 32-bit integer.

Output

For each problem instance, output a single line containing the corresponding LCM. All results will lie in the range of a 32-bit integer.

Sample Input

2
3 5 7 15
6 4 10296 936 1287 792 1


Sample Output

105
10296#include<stdio.h>
long cm(long m,long n)
{
if(m>0&&n>0)
{
long a,b,r;
if(n>m)
{
r=n;
n=m;
m=r;
}
a=m;
b=n;
while(r!=0)
{
r=a%b;
a=b;
b=r;
}
return m/a*n;
}
else
return 0;
}
int main()
{
int i,n,a,b,t;
scanf("%d",&t);
while(t--)
{
scanf("%d%d",&n,&a);
for(i=1;i<n;i++)
{
scanf("%d",&b);
a=cm(a,b);
}
printf("%d\n",a);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: