您的位置:首页 > 理论基础 > 数据结构算法

数据结构--AC自动机--模板

2014-03-17 19:31 141 查看


Keywords Search

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 30354    Accepted Submission(s): 9910


Problem Description

In the modern time, Search engine came into the life of everybody like Google, Baidu, etc.

Wiskey also wants to bring this feature to his image retrieval system.

Every image have a long description, when users type some keywords to find the image, the system will match the keywords with description of image and show the image which the most keywords be matched.

To simplify the problem, giving you a description of image, and some keywords, you should tell me how many keywords will be match.

 

Input

First line will contain one integer means how many cases will follow by.

Each case will contain two integers N means the number of keywords and N keywords follow. (N <= 10000)

Each keyword will only contains characters 'a'-'z', and the length will be not longer than 50.

The last line is the description, and the length will be not longer than 1000000.

 

Output

Print how many keywords are contained in the description.

 

Sample Input

1
5
she
he
say
shr
her
yasherhs

 

Sample Output

3

 

Author

Wiskey

 

Recommend

lcy

 
建议:
懂了AC自动机的原理在往下看吧~~~
#include "cstdio"
#include "queue"
#include "cstring"
#include "iostream"
using namespace std;

struct node
{
int count;  //是否为该单词的最后一个节点
node *fail;   //失败指针
node *next[26];  //Tire每个节点的26个子节点(最多26个字母)
node()   //构造函数初始化
{
count = 0;
fail = NULL;
memset(next,NULL,sizeof(next));
}
};

char str[1000005];  //模式串

void Insert(char *s,node *root)    //建字典树
{
node *p = root;
int i,index;
for(i=0; s[i]!='\0'; ++i)
{
index = s[i]-'a';
if(p->next[index]==NULL)
p->next[index] = new node();
p = p->next[index];
}
p->count++;
}

void Build_ac_automation(node *root)  //建立失败指针
{
int i;
root->fail = NULL;
node *p,*temp;
queue<node *> q;
q.push(root);
while(!q.empty())   //bfs构造失败指针
{
temp = q.front();
q.pop();
p = NULL;
for(i=0; i<26; ++i)
{
if(temp->next[i]==NULL) continue;
if(temp==root)
{
temp->next[i]->fail = root;
q.push(temp->next[i]);
continue;
}
p = temp->fail;
while(p!=NULL)
{
if(p->next[i]!=NULL){
temp->next[i]->fail = p->next[i];
break;
}
p = p->fail;
}
if(p==NULL)
temp->next[i]->fail = root;
q.push(temp->next[i]);
}
}
}

int Query(node *root)
{
int i=0;
int cnt=0,index;
node *p = root;
for(i=0; str[i]!='\0'; ++i)
{
index = str[i]-'a';
while(p->next[index]==NULL &&p!=root)
p = p->fail;   //p指向p的失败指针所指向的节点
p = p->next[index];   //p指向index节点
p = (p==NULL) ? root:p;
node *temp = p;
while(temp!=root && temp->count!=-1)
{
cnt += temp->count;
temp->count = -1;  //已经统计过的字符串不用再次统计
temp = temp->fail; //temp指向e的失败指针说指向的节点继续查找
}
}
return cnt;
}

int main()
{
int T;
int n;
char s[51];
scanf("%d",&T);
while(T--)
{
node *root = new node();
scanf("%d",&n);
getchar();
while(n--)
{
scanf("%s",s);
Insert(s,root);
}
Build_ac_automation(root);
scanf("%s",str);
printf("%d\n",Query(root));
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签:  数据结构